Definitely leaving NomadBsd

I have been using Nomad, as a computer enthusiast, for about three years, but I am going to stop using it due to the errors shown in the latest versions.
As already reported in the posts Neither ZFS nor UFS, NomadBSD 140R: Upgrade of perl5 from 5.34.1_3 to 5.34.3_3 not working, NomadBSD 14.0-RELEASE FreeBSD 14.0-RELEASE #0 and in Fail to create hardlink NomadBSD version 132R-20231013, the error in the Perl update has not been corrected and it is impossible to update some packages.
Today I reinstalled NomadBSD 140R on a 64GB USB and tried to update the system, but it showed the error with Perl again as shown in the attached screen.


It is the same error already reported, so only by blocking Perl you can use Nomad, but it does not seem like the correct solution.
To summarize, neither with OpenIndiana, nor with Manjaro, nor with Haiku, even with Windows there are these problems, therefore I will not use Nomad again.

in this post seems to me that Gulliver had confirmed how to solve this issue in his last reply, then maybe you have also tried unsuccessfully

NomadBSD 140R: Upgrade of perl5 from 5.34.1_3 to 5.34.3_3 not working - Help Section - NomadBSD Forum

Hello Mauro.
The problem with hardlinks comes from version 132R (October 23) and it seems that they were resolved with 140R (November 23), but that was not the case.
Today I downloaded the 140R and copied it to a clean USB with Balena Etcher from Windows and then I ran the installation on the USB itself, apparently completing well.
Once the USB was restarted, I ran OctoPkg to update the system and the error with Perl reappeared.
Gulliver’s solution could work, but it doesn’t seem to make much sense to make a “bridge” with another USB to solve the error.
I know that Nomad is not a rolling release, but I think it doesn’t make much sense to have to completely reinstall the system for each new version or fix problems with some packages, as is the case with Perl.

The solution described earlier definitely works for me.
Today there was a major 140R upgrade of more than 400 packages, including perl5, from 5.34.3_3 to 5.36.3_1. The update of the packages on the ‘settler’ USB stick created with the NomadBSD installer went absolutely smoothly.

Perl5_2024-01-17_21-19-42

That’s because you’re using the original image. Use the installer included, I think it’s under the system submenu and install it on another USB or another physical drive and your problem is solved.

That’s right. The problem is in the original image, since it does not make any sense that a system defined as “NomadBSD is a persistent live system for USB flash drives, based on FreeBSD®” forces, to avoid the reported error, to install it on another USB or HDD.

Until version 131R (December '22) this error did not occur, and the system could be updated on the USB itself without problems. It was from version 132R (October '23), when hardlink errors began to appear and version 140R (November '23, only 43 days after!) was created, in my opinion hastily.

Today I installed NomadBSD on an HDD with Settler as the user and it worked well, according to Mauro. However, once installed and completely updated (about 400 packages), I tried to create a new user and apparently it did well, but then it did not allow me to start the system from this new user, even though I had the same permissions and accesses as Settler, unable to log in reporting an “xterm definition error”.

These are the user definition screens

Captura de pantalla_2024-01-19_11-54-23

The error that appears when trying to start NomadBSD with this user is: “There is no user-session or usable default with xterm”.

As I said before, until version 131R I was able to use NomadBSD normally, and it was from 132R onwards that it stopped working as expected, so in view of the errors and in my opinion poor configuration or compilation of version 140R, I will not use NomadBSD again.
As they say, it was nice while it lasted.
Greetings to all users.

1 Like

Well, when I did it I didn’t accept the default user ‘settler’ and change it to ‘ecerejo’ but I haven’t created any other user. I never had any problems except the installation did not install the lib32 libraries and wine gave me problems until I figured out that those libraries were missing.

1 Like

Hi idude 0407, just to know, have you then solved this? Just because I’ve also tried the installation of wine by the available packages, but win32 software can’t start due to 32 bit supporting software missing, and appearently there is no separate package available to install for this purpose.
Also opened another topic about it
How to provide Wine 32 bit in NomadBSD 14.0 - Help Section - NomadBSD Forum.
a-bateman -who here I thank again- had posted a solution which I found a bit “tricky” to try.

Sorry for the delay. Yes I solved it. You have to have the lib32 files for freebsd. Unfortunately nomadbsd doesn’t give you an option to install them so you have to download them from the freebsd site. After that just extract it into your /usr directory. You might have the directory in there already but it’s empty.

Easiest way is to download it into your download directory and than just run:
tar -C / -xpf lib32.txz

thank you much

Make sure you run winecfg first. It it asks to install mono just click yes.

wow…!
It worked.
Thank you a lot :slightly_smiling_face:

Great! From now on every time you use:
#pkg upgrade -y

You must also run (as a regular user)
/usr/local/share/pkg32.sh upgrade -y