Fail to create hardlink NomadBSD version 132R-20231013


Thank you for the new NomadBSD version 132R-20231013.

NomadBSD is a wonderful distribution !

I downloaded version NomadBSD 132R-20231013 (64-bit/x86-64/amd64, UFS)

After the installation I did an update and I get this error “Fail to create hardlink” see below

nomad@NomadBSD$ sudo pkg update
Updating FreeBSD repository catalogue…
Fetching meta.conf: 100% 163 B 0.2kB/s 00:01
Fetching packagesite.pkg: 100% 7 MiB 1.7MB/s 00:04
Processing entries: 100%
FreeBSD repository update completed. 34069 packages processed.
All repositories are up to date.
nomad@NomadBSD$ sudo pkg upgrade
Updating FreeBSD repository catalogue…
FreeBSD repository is up to date.
All repositories are up to date.
Checking for upgrades (8 candidates): 100%
Processing candidates (8 candidates): 100%
The following 4 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
libX11: 1.8.6_1,1 → 1.8.7,1
libXpm: 3.5.15 → 3.5.17
libudev-devd: 0.5.1 → 0.5.2
llvm15: 15.0.7_6 → 15.0.7_7

Number of packages to be upgraded: 4

139 MiB to be downloaded.

Proceed with this action? [y/N]: y
[1/4] Fetching libX11-1.8.7,1.pkg: 100% 2 MiB 1.6MB/s 00:01
[2/4] Fetching llvm15-15.0.7_7.pkg: 100% 137 MiB 2.1MB/s 01:09
[3/4] Fetching libXpm-3.5.17.pkg: 100% 91 KiB 93.5kB/s 00:01
[4/4] Fetching libudev-devd-0.5.2.pkg: 100% 17 KiB 17.4kB/s 00:01
Checking integrity… done (0 conflicting)
[1/4] Upgrading libX11 from 1.8.6_1,1 to 1.8.7,1…
[1/4] Extracting libX11-1.8.7,1: 100%
[2/4] Upgrading llvm15 from 15.0.7_6 to 15.0.7_7…
[2/4] Extracting llvm15-15.0.7_7: 2%
pkg: Fail to create hardlink: /usr/local/bin/.pkgtemp.bugpoint15.UPqY9AuYSkkI ↔ /usr/local/bin/.pkgtemp.dsymutil15.WNRyKcqLdu0D:File exists
[2/4] Extracting llvm15-15.0.7_7: 100%

nomad@NomadBSD$ uname -a
FreeBSD NomadBSD 13.2-RELEASE-p4 FreeBSD 13.2-RELEASE-p4 NOMADBSD amd64

It seems that another person had an equivalent problem.

Do you have the same error? Is it related to Fusefs unionfs?

Thanks a lot

Maybe a modification in the code as for “sysutils/e2fsprogs” some time ago

sysutils/e2fsprogs breaks pkg upgrade
The latest version of sysutils/e2fsprogs tries to replace some symlinks with hardlinks [1]. This is not possible on NomadBSD (live system) due to the fact that / and /usr/local are two different filesystems. The result is an uncomplete upgrade which breaks some applications.

I don’t think it’s possible to work around this problem, other than waiting for a new package to fix this bug (or not) or rebuilding the image with the latest version (llvm15-15.0.7_7) but which can happen again with another version of llvm15.


There is a serious issue in NomadBSD 132R-20231013. It’s impossible update due to an error showed in the next screen:

Although package llvm15-15.0.7_6 must be updated with package llvm15-15.0.7_7, the system indicates that the file already exists and the process does not continue.
It seems that the system does not recognize the new packet, reporting that the destination already exists, and the update is aborted. This is the error:

Even blocking package llvm15-15.0.7_7, the system includes the lite package, which again shows the same error above: “it installs files in the same place”.

@mrclksr updated the git with the freebsd 14.0 version, I think a new image should arrive integrating llvm15-15.0.7_7
hoping there won’t be any other packages with hardlink error


I’m happy to report I have successfully built an image using FreeBSD 14.0-RELEASE.

1 Like


I think @mrclksr is working on a fix
“Fix for hard link creation errors on unionfs”

I hope this will resolve these errors with perhaps a new image in the next few weeks.

Thank you for this development.

The problem will be resolved in the next release. Until then, see the NomadBSD 140R-20240126 Errata for a solution.

1 Like

Thanks for your feedback and the work

1 Like