Won't install -- screen goes black -- then has to be rebooted -- then goes black again

I’m using a 6 yr old Lenovo laptop with Atrixlinux installed. I downloaded the 1.4 amd64 file. The checksum was fine. Then extracted the .img file and ran the checksum on it. Everything was fine.

When I boot from the USB, it’s booting from an efi file. It seems to start okay. I get past the logo and boot options. It goes through some stuff, and then my screen goes blank. I tried rebooting and nothing happens. I was hoping to put Nomad on the pen drive.

I removed the pen-drive. I’ve tried it 2-3 times, and it seems like it takes a few attempts to get Atrixlinux to fire up again.

I see a few related posts to the right of this textarea with similar posts, but quite a few of them are mentioning problems with Nvidia graphics adaptor – but I’m not using Nvidia.

1 Like

Try checking your bios for two things that gave me trouble on my Dell: I had to disable Secure Boot and all its options and I had to set the fast-boot options to the slowest setting. The fast-boot options select certain functions to be started later in the boot process, such as USB ports, to speed up the boot process. Set to the slower option, the USB ports are enabled early in the process, allowing the laptop to boot from a USB mem stick.

Also, when I installed to the hard drive from my usb stick, I noticed there was an option to select something called “lenovofix” to install in the boot process. I don’t know what that’s about, but it might be something to “google.”

Thank you.

My problem is described in the handbook:

If you are booting a system with ATI/AMD graphics via UEFI, you might experience some problems. Due to a conflict with the EFI framebuffer, NomadBSD might crash or hang when the graphics driver gets loaded, or it just isn’t able to start the X window system.

Try the following workaround:

  1. (Re)boot and enter the boot submenu Boot Options ( 6 ).
  2. Change Disable syscons to On by pressing the key matching the item number.
  3. Go back to main menu, and press <Enter> to boot.

It booted up, and the GUI loaded after following these instructions. I’m curious about the “lenovofix” and, what it might be. I made a note of it to look it up.

Thank you.

Thank you for this answer. I have an old Dell. It is a studio I-7. My screen went black when I updated the system. I will try the method you instructed.

1 Like

Hello @Donald,
did you read the NomadBSD Errata.
If the system was working and it happened after an update, you might find a solution here.

Helo @Steve,
You are aware that NomadBSD 130R-20210508 is the newest version?

No, I wasn’t aware of it. Newer versions of most software have higher numbers. What’s the method to upgrade to the newer version? Or is it easier to download the new image file and re-install?



it’s my impression that due to the way the distribution is put together, it’s easier to reinstall with a new image.
Remember to backup your home-folder and the .conf-files you made changes to.

The naming convention got changed between the two versions (here’s a post).
[below written WITHOUT snark intent!]
(130 or 13.0 [refer to FreeBSD version number] is still a greater version number than 1.4 :wink: , but I can definitely see the risk for misreading! -and I might have done the same, if I arrived at the project today)

Have a nice day

Ludensen, a happy NomadBSD-user

Thank you!