Screen Resolution 1920x1080 is not supported

Hi !
I can’t find my 1920x1080 screen resolution, I’ve tried everything and can’t get it.
I also installed nvidia-driver and nvidia-settings and can’t do anything either.
I have an intel i5-9400 and a Nvidia GeForce GTX 1650 graphics.

I couldn’t solve it from here either. ↓

judd@NomadBSD:~% grep vesa /var/log/Xorg.0.log
[    73.754] (II) LoadModule: "vesa"
[    73.784] (II) Loading /usr/local/lib/xorg/modules/drivers/vesa_drv.so
[    73.786] (II) Module vesa: vendor="X.Org Foundation"
[    73.898] (II) VESA: driver for VESA chipsets: vesa

judd@NomadBSD:~% grep kld_list /etc/rc.conf
kld_list="cuse4bsd"

judd@NomadBSD:~% kldstat | grep i915kms.ko
judd@NomadBSD:~%


judd@NomadBSD:~% xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768       0.00* 
   800x600        0.00  
   640x480        0.00  

# pciconf -lv | grep -A4 vgapci
vgapci0@pci0:1:0:0:	class=0x030000 rev=0xa1 hdr=0x00 vendor=0x10de device=0x1f82 subvendor=0x1458 subdevice=0x3fca
    vendor     = 'NVIDIA Corporation'
    device     = 'TU117 [GeForce GTX 1650]'
    class      = display
    subclass   = VGA

/var/log/messages → https://pastebin.com/raw/pfVgKGee


judd@NomadBSD:~% freebsd-version -uk
13.0-RELEASE
13.0-RELEASE

Thanks, as always !

Hi @judd,

are you running it from a flash drive or did you install it on a HDD/SSD? If the latter is true:

# sysrc kld_list+=" /boot/modules/nvidia-modeset.ko /boot/modules/nvidia.ko"

After a reboot it should work.

Good morning @mk1 !

Unfortunately it did not work.

root@NomadBSD:/home/judd # sysrc kld_list+=" /boot/modules/nvidia-modeset.ko /boot/modules/nvidia.ko"
kld_list: cuse4bsd /boot/modules/nvidia-modeset.ko /boot/modules/nvidia.ko -> cuse4bsd /boot/modules/nvidia-modeset.ko /boot/modules/nvidia.ko
root@NomadBSD:/home/judd # 

:thinking:

If the file /usr/local/etc/X11/xorg.conf.d/00-video-initgfx.conf does not exist, or doesn’t contain the line Driver "nvidia", create the file with the content

Section "Device"
    Identifier    "NVIDIA CARD"
    VendorName    "NVIDIA Corporation"
    Driver        "nvidia"
EndSection

Then reboot.

It did not work.
This is what was in that file, before I changed the content ↓

What does pkg info | grep nvidia say? Could please post the content of your /var/log/Xorg.0.log?

root@NomadBSD:/home/judd # pkg info | grep nvidia
nvidia-driver-460.67           NVidia graphics card binary drivers for hardware OpenGL rendering
nvidia-settings-460.67         Display Control Panel for X NVidia driver

https://pastebin.com/raw/4zz2v19N

What does grep -i vesa /usr/local/etc/X11/xorg.conf.d/* say?

root@NomadBSD:/home/judd # grep -i vesa /usr/local/etc/X11/xorg.conf.d/*
/usr/local/etc/X11/xorg.conf.d/00-video-initgfx.conf:	Driver "vesa"

I thought you changed that file as I wrote here

I did indeed change that file, moreover, I tried this:

Section "Device"
       Identifier       "GTX 1650"
       Driver           "nvidia"
EndSection

and it didn’t work either

I need to see /var/log/Xorg.0.log with Driver set to "nvidia" to see what’s wrong. Also, are the nvidia modules loaded (kldstat | grep nvidia)?

# kldstat | grep nvidia
10    1 0xffffffff82353000   10b310 nvidia-modeset.ko
11    1 0xffffffff82600000  1e83468 nvidia.ko

What does grep initgfx /etc/rc.conf say?

root@NomadBSD:/home/judd # grep initgfx /etc/rc.conf 
initgfx_enable="YES"
root@NomadBSD:/home/judd # 

Ah, there is the problem. initgfx is enabled, and is therefore overwriting your /usr/local/etc/X11/xorg.conf.d/00-video-initgfx.conf. Disable it (sysrc initgfx_enable=NO), then change the content of /usr/local/etc/X11/xorg.conf.d/00-video-initgfx.conf as described here, and reboot.

1 Like

WORKED !!!
Sorry for the delay in replying, but I have to translate…

THANK YOU VERY MUCH FOR YOUR ATTENTION AND YOUR TIME !

Excellent! Thank you for your patience :slight_smile:

I will put the steps in an errata file.

1 Like