No WiFi interface

No WiFi connection with Dell 9350 laptop. Error message “ No WiFi interface is configured in /etc/rc.conf.

Please provide the output of the command pciconf -lv | grep -B3 network .

BSD doesn’t have very good Wifi support, this isn’t a rant but reality. Your best bet is, if you look through approps for wifi drivers and buy one at amazon normally intel, and atheros are good but they don’t sell dongles just integrated, and this causes some issues with PCIID blocking, meaning some companies will block your pcim wifi. But even those tend to lack I have a 9565 Intel which isn’t supported. I have a backup I use when this happens.

Sorry to barge in but I have the same problem.
Can you help me? I’m new to BSD and I don’t know Linux either so please be gentle.
The output is as follows:

bfe0@pci0:3:0:0: class=0x020000 card=0x01891028 chip=0x170c14e4 rev=0x02 hdr=0x00
vendor = ‘Broadcom Inc. and subsidiaries’
device = ‘BCM4401-B0 100Base-TX’
class = network

iwi0@pci0:3:3:0: class=0x028000 card=0x10208086 chip=0x42238086 rev=0x05 hdr=0x00
vendor = ‘Intel Corporation’
device = ‘PRO/Wireless 2915ABG [Calexico2] Network Connection’
class = network

I also have a USB adaptor with Atheros 9271 chip, why it doesn’t show?

In place of wlan0 you can use usb tethering… its works on nomadbsd.

usb tethering is done via RNDIS protocol which by default is supported by FreeBSD. So As I have tried to enable that same protocol on NomadBSD! to my surprise it’s worked.

–Command…
Before doing this disconnect the mobile from PC
First check if kernel rndis driver is loaded or not…

kldstat | grep uf_urndis

it should produce something like this…
21 1 0xffffffff82929000 2760 if_urndis.ko

If not shown then use this command…

kldload if_urndis

then check again by using the previous command.
It will show the upper mentioned result

Connect your mobile, enable usb tethering.
use this command to check if any device is connected or not

dmesg | grep -i USB

You will can see your mobile device name, either by chipset name or device manufacturer name
From here if everything is ok, type the below command…

ifconfig

You will be able to see a list of ethernet devices enabled on your pc, out of which
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
ether 00:e0:4c:a2:73:13
inet6 fe80::2e0:4cff:fea2:7313%re0 prefixlen 64 scopeid 0x1
media: Ethernet autoselect (none)
status: no carrier
nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=680003<RXCSUM,TXCSUM,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
inet 127.0.0.1 netmask 0xff000000
groups: lo
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>

ue0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

ether 02:0d:5b:0d:36:65

hwaddr 02:0d:5b:0d:36:65

inet 192.168.1.103 netmask 0xffffff00 broadcast 192.168.255.255

nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>

Out of which ue0 device is the connected usb tethered device, though seems connected but you’ll not get the ethernet, so type this command.

dhclient ue0

Run ‘ifconfig’ command again you will see ip address under ue0 section, if you will see, there you have the internet on nomadbsd. The dhclient ue0 command need to be typed everytime you boot, but if you don’t want to do that then, edit bootloader file…
type this command

sudo gvim /boot/loader.conf

this will ask you the password you had set during setup… type and let GVim open the file.
Enter this…
#Enabling rndis protocol driver auto loading
if_urndis_load="YES
then save and close. Log out the window and log in again you can then use ethernet on nomadbsd. Here my urndis info and ping data, enabled Jio Router(India) on NomadBSD.

Thanks, I appreciate your help but…
I don’t have a mobile device available and even if I had one, I’m so new at all this that I’d be lost running all those commands. In fact, I don’t even know where to type them.
This OS seems very complicated for newbies, perhaps I should stick to Windows and forget about it.

Thanks again, cheers!

That’s your wish but if you really like to know existing os other than linux and windows then in my opinion NomadBsd is really a nice FreeBSD distro for lots of new learner wishing to learn BSD unix. Anyway if you want learn more of FreeBSD and it’s function visit https://freebsd.org because lots of problems which may be seen on nomadbsd can be solved following freebsd documentation as nomadbsd is self is a freebsd distribution.

I visited that page and many others while searching for a solution but they ALL talk in too technical terms, like if everybody knows BSD or Linux.

At my age I’m not interested in learning new OSs, just wanted to donate CPU time for Folding@Home on this old 32bit laptop and NomadBSD persistant live USB installation seemed like the best choice for simplicity and speed.

I also tried Balena Cloud Rosetta@Home and that didn’t work either, it won’t even boot.

Your card should be supported by the bfe driver (man 4 bfe). Put the line

if_bfe_load="YES"

in /boot/loader.conf end reboot the PC.

Thanks for replying.

The ethernet connection works just fine, I want to connect via wi-fi
There’s the Intel adapter shown in the output above and a USB adapter with Atheros 9271 chip which doesn’t even show.

Any ideas? TIA

This should be supported by iwi(4) driver, put these lines in /boot/loader.conf

if_iwi_load="YES"
wlan_load="YES"
firmware_load="YES"

Hi Maurizio,

I’ve tried your suggestion but it won’t let me save/overwrite the modified config file.

Message: "Can’t open file to write"

Also, two questions:
Does it matter where to insert those lines?
Shouldn’t all 3 “YES” be in between quotes or just the last two as in your example?

sudo geany /boot/loader.conf

Where you want, but I usually put my lines above this line:
vfs.root.mountfrom="zfs:zroot/ROOT/xxxxxxx"

Sorry, I have forgotten a quote, now will I correct the post.

ok thanks!
I’ll try again later after making a new USB installation, this one went to hell and it won’t boot

Bad news, it didn’t work.
Network manager shows nothing to connect to…

edit: not even ethernet is working now…

Usually, if a device is supported, DSBDriverd should find and load its device driver, and configure the network interface, so there is no need to edit /etc/rc.conf. The output shows that the drivers are loaded, and DSBDriverd should have created a wlan0 device (please check the output of ifconfig).

Because it’s a USB device. Use usbconfig dump_device_desc to show the USB device descriptions. But AFAIK the Atheros 9271 chip is not supported by FreeBSD.

I’m confused, Maurizio advised me to edit /boot/loader.conf so which of the two should I edit if any?

nomad@NomadBSD ~> ifconfig
bfe0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=80008<VLAN_MTU,LINKSTATE>
ether 00:11:43:79:63:31
inet6 fe80::211:43ff:fe79:6331%bfe0 prefixlen 64 scopeid 0x1
inet 192.168.0.159 netmask 0xffffff00 broadcast 192.168.0.255
media: Ethernet autoselect (100baseTX )
status: active
nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=680003<RXCSUM,TXCSUM,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
inet 127.0.0.1 netmask 0xff000000
groups: lo
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>

Also, apparently the Atheros adapter its being recognized

nomad@NomadBSD ~> usbconfig dump_device_desc

ugen4.2: ATHEROS USB2.0 WLAN> at usbus4, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (500mA)

bLength = 0x0012
bDescriptorType = 0x0001
bcdUSB = 0x0200
bDeviceClass = 0x00ff
bDeviceSubClass = 0x00ff
bDeviceProtocol = 0x00ff
bMaxPacketSize0 = 0x0040
idVendor = 0x0cf3
idProduct = 0x9271
bcdDevice = 0x0108
iManufacturer = 0x0010
iProduct = 0x0020 <USB2.0 WLAN>
iSerialNumber = 0x0030 <12345>
bNumConfigurations = 0x0001

ugen means generic USB driver which means it is not supported.

use approps to find a suitable supported USB wifi adapter. BSD does not have the same wifi support as Linux does.

NDIS is not a well suited replacement for lack of drivers it is not even suitable for daily use. If it works it is due to more of luck than anything.

ALL USB devices start with ugenx.x so I guess nothing is supported then…