[Help] How can i make my speaker sound louder?

Hello, its been a few day since i install and use nomadBSD.
its feel so surprised how fast its run, event i run it on old SD card.

i have problem with my speaker sound. the volume is really low. even in 100% volume

how can i make my speaker sound louder?

i do search my self but honestly i dont really know what am i doing,
i think i got some info about my hardware by running :

dmesg | grep pcm

the output :

dmesg | grep pcm.
pcm0: <Conexant CX20751/2 (Analog)> at nid 23 and 26 on hdaa1
pcm1: <Conexant CX20751/2 (Left Analog)> at nid 22 and 25 on hdaa1

please explain slowly with me. iam beginner.

thankyou for your attention and help.

Hello its me again,
i messed it up again. i dont know how this was happen but
The sound is gone. my laptop speaker didn’t produce any sound right now

but there is a sound when i try using headphone .

i confirm that my laptop speaker hardware is fine and not broken. because its work with my manjaro and windows10

Make sure the PCM channel is 100%, too. Furthermore, you can amplify sound by reducing Amplification value (dB) in DSBMixer: File->Preferences->Advanced. Try 12. Values too low will lead to clipping.

Did you change the default audio device?

Hello there hecate02,

I had the same issue on a MacBook Pro Mid-2015. No sound. First, I opened up a terminal and and typed the following as root:

dmesg | grep pcm

This will list all sound devices and (should) name your hardware. ( This may detect your internal speakers)
My speaker fails to be addressed but is available through my headphone port. And this port is named as unit 2. So this code sorted the problem:

sysctl hw.snd.default_unit=2

NomadBSD, as far as I can tell, loads audio/sound kernel modules automatically so you don’t have enable them by typing as root in the command line:

kldload snd_driver

I opened an audio application (Audacious) and there was sound and music loud and clear, but only through the headphone port. This is not a brilliant solution but is OK for me since I have, and am happy to use external speakers.

I hope this helps.

So long.

Hello again hecate02,

Also try the command mixer in the terminal.
By typing mixer you should get something like this:

Mixer vol is currently set to:85:85
Mixer pcm is currently set to 90:90

By typing:

mixer vol 100

or

mixer pcm 100

…you’ll get more volume.

Hope this helps.