Can't start Xorg on my asus vivabook laptop Ryzen 3 , Vega 3 gpu

Can’t start Xorg on my asus vivabook laptop Ryzen 3 , Vega 3 gpu
If i don’t disable the syscons xorg show a message that i have to set some address for something (framebuffer??)
When i disable syscons and boot at first i see some details about efi framebuffer i succeed waiting for some time and start but the next time i tried to boot my laptop it stucked on efi framebuffer information
and doesn’t do anything anymore ! Can’t do anything can’t change terminal can’t do anything on the installed system .
Is there a way to make vega 3 gpu and EFI to work together ?? because my laptop doesn’t support booting from non-efi partitions there are no settings on bios.

Newer machines aren’t that supported. if it doesn’t work it normally means you need to manually install a driver or it’s not supported.

If i try with radeon ? maybe its compatible ?

probably not

becuase this is a 20 char minimum fgfgfgfgfgfgfgfgfgfg

Is there anything i can do ?
This is pretty annoying and i can’t fix that.

not really if you don’t have the time or the coding to do so. this is why BSD fails as a desktop

I remember on my media center with a plain ryzen3 minipc i had a problem where i came upon a black screen , i passed the parameter amdgpu.dc=0 or 1 on kernel option and this fixed it. If i use linuxkpi amdgpu.dc would it fix it ?

BSD isn’t the same as Linux. The API kernel is different.

You need to see if installing the Radeon x driver would make it work. You could try to install current but that requires some know how as it’s dev version

On FreeBSD 13 with drm-devel-kmod i managed to start xorg disabling syscons but only for about two-three times then nothing ! When i succeed booting xorg (slim/openbox) touchpad worked with iichid , sound and wifi worked out of the box .
I suspect that i must use linuxkpi amdgpu.dc=0 or 1 something…
I’m completely dissapointed

You can play with the sysctl’s and add them to /etc/sysctl.conf you can see which ones would be the equivalent to amdgpu.dc=0. However as mentioned before if the OS takes hours to setup it fails as a Desktop OS.

i found a solution without disabling syscons but has problems on lightdm no keyboard , i may try other display managers too, sound works ok