Cant boot USB with nomadBSD

so I decided to try nomadBSD so I tried to install it onto USB number 1 I installed the img from the website formatted the the usb with an disk app on Ubuntu and then used dd bs=1M if=nomadbsd-x.y.z.img of=/dev/sda conv=fsync to put it on to the disk it finished and I rebooted my PC boot from the USB and I get a


but I had problems with this USB before when I tried to live boot kali from it so I tried a second USB that I know that works and can live boot because I used tails on it at least 5 times so I do the exact steps except I dont download a new file from the website just use the same one I downloaded before so I format the USB install nomadBSD on it and try to boot same thing so now I dont know what is wrong and what should I do should I download the img again should I check if it broken with some tool what should I do

Hello my dear,
did you check the secure boot option in your BIOS?
That one is often turned on to prevent booting a different OS, because this could be abused.