Worked on my Desktop

Hi there, I am new to this nomad community. Recently found this new FreeBSD distribution on the internet and though being a linux person wanted to try some FreeBSD distribution for long. Used PC-BSD but it was not upto that mark of being a normal desktop os.
Thanks to Nomad Teams for making this nice FreeBSD distros. Posted my system info here which was saved from nomad modified sysinfo command, nomad-sysinfo.

Output of the system info can be found here…

3 Likes

I have successfully enabled a usb tethered device on NomadBSD… Following are the process described.

usb tethering is done via RNDIS protocol which by default is supported by FreeBSD. So As I have tried to enable that same protocol on NomadBSD! to my surprise it’s worked.

–Command…
Before doing this disconnect the mobile from PC
First check if kernel rndis driver is loaded or not…

kldstat | grep uf_urndis

it should produce something like this…
21 1 0xffffffff82929000 2760 if_urndis.ko

If not shown then use this command…

kldload if_urndis

then check again by using the previous command.
It will show the upper mentioned result

Connect your mobile, enable usb tethering.
use this command to check if any device is connected or not

dmesg | grep -i USB

You will can see your mobile device name, either by chipset name or device manufacturer name
From here if everything ok, type below command…

ifconfig

You will be able to see a list of ethernet devices enabled on your pc, out of which
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

options=209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC>

ether 50:65:f3:1f:7b:3c

hwaddr 50:65:f3:1f:7b:3c

inet 192.168.1.126 netmask 0xffffffff broadcast 192.168.1.126

nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>

media: Ethernet autoselect

status: no carrier

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384

options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>

inet6 ::1 prefixlen 128

inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2

inet 127.0.0.1 netmask 0xff000000

nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>

groups: lo

ue0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

ether 02:0d:5b:0d:36:65

hwaddr 02:0d:5b:0d:36:65

inet 192.168.42.89 netmask 0xffffff00 broadcast 192.168.42.255

nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>

Out of which ue0 device is the connected usb tethered device, though seems connected but you’ll not get the ethernet, so type this command.

dhclient ue0

Run ‘ifconfig’ command again you will see ip address under ue0 section, if you get to see that, there you have the internet on nomadbsd. The dhclient ue0 command need to be typed everytime you boot, but if you don’t want to do that then, edit bootloader file…
type this command

sudo gvim /boot/loader.conf

this will ask you the password you had set during setup… type and let GVim open the file.
Enter this…
#Enabling rndis protocol driver auto loading
if_urndis_load="YES
then save and close. Log out the window and log in again you can then use ethernet on nomadbsd. Here my urndis info and ping data, enabled Jio Router(India) on NomadBSD.

1 Like

In order to auto load the usb tethered device during boot or just when connected, users need to enter a command in the /etc/rc.conf file
Command

sudo gvim /etc/rc.conf

password will be asked, enter the password given during set up
then when the file will be opened enter
ifconfig_ue0="SYNCDHCP"
then save the file and logout and log in again.

Also if anyone wants to see the ethernet logo on the top title bar, install networkmgr using the following command…

sudo pkg install networkmgr

and add the programs ‘networkmgr’ entry using the ways shown here,
https://nomadbsd.org/handbook/handbook.html#autostart

3 Likes

Thank you, this is a very helpful How-To! :partying_face:

Thanks and welcome by the way now working to find any ways to solve the usb 3g problem. Modem ZTE MF190. Though shows under u3g section but dialing default ppp does not work.