USB install -> YES desktop, NO Toshiba Portege M750

Installed NomadBSD on an USB Sick and it wouldn’t boot on my ten-years old convertible Toshiba Portege M750[Intel Core 2 Duo P8600 – 4GB-RAM].

I thought if it would have a first-boot on another machine, it would also work on the convertible. It indeed booted and initialized on a 4GB-RAM desktop with a DualCore D8800 with only the CPU Intel integrated videocard.

But it still freezes with a backslash and a flashing prompter [both on the same character] in the upper-left corner of the booting console.

Nothing? I would really appreciate a hint here!

Btw: The Toshiba is a Centrino2 if it helps…

Hi there @pniky,

welcome to the forum, and sorry for the delay.

Which version of NomadBSD are you using? Does it still boot on your desktop system? Have you tried all booting modes of your Toshiba (Legacy, CSM, UEFI)?

I downloaded the last one: 1.3.1 (amd64).

As for booting modes, this toshiba is from 2009, it doesn’t know about UEFI.

About CSM, here it’s me the one who doesn’t know about it. In Romania it means Council Supreme of Magistrates, but I reckon that’s not what you meant.

CSM = Compatability Support Module

1 Like

OK. First – I forgot to mention – it still boots on the desktop [and, I guess, on ANY desktop].

Second, my Toshiba Portege M750 being a 2009 model, it has not UEFI of any kind, so only legacy boot is available. I use to invoke boot menu with F12. It looks like this:

Note the menu at the bottom from which one can select with horizontal arrows and validate with ENTER. For USB booting I have only the last option, selected like this:

After I press ENTER, it freezes like I said. Would a photo of the freeze help? I took a 5 secs video to see the blinking cursor, but It seems that I can’t upload videos – only photos permitted.

:slightly_smiling_face: NIKY :wink:

Two more things you can try are:

  1. Try to use a different USB port. I have a Toshiba Satellite, where one port is terrible slow and unreliable.

  2. Instead of Toshiba’s boot menu, try to enter the BIOS (F2) and make the USB stick the first boot device. I don’t know why, but when I use the boot menu of my Asrock MB, NomadBSD either hangs or the USB port disconnects.

  1. Tried all 3 USB ports with the same result: minus sign and blinking cursor in the top-left character of the booting console screen.
  2. Changed the order of the HDD booting devices to “USB boot -> built-in HDD -> second HDD” with the same above result.

I have to give this to the bloddy thing: it has consistent reactions whatever I try – this being in fact no reaction at all…

Can you boot the FreeBSD-12.1-RELEASE-amd64-mini-memstick.img image?

Nope! It does the same thing!

Unfortunately, there is nothing we can do about it. However, you could consult the freebsd-bugs mailing list.

I’d check if there may be a BIOS update. The spinning ‘/’ character indicates different steps during boot for where it is in the rotation if I recall so could be helpful if opening up an issue with the FreeBSD project directly. I’d suspect they may ask you to get some information from the system that they can use to patch around a buggy BIOS call. Is that correct that it will still boot the USB copy even after attempting the install to hard drive which stops booting (and these are the same machine right)?

Did you try to boot your laptop with this USB stick and a different OS like Knoppix, Ubuntu or a different BSD? Just to see if you are able to boot anything with this stick. Gparted live iso is a good choice for testing as well.

I thought myself to ask for help on FreeBSD forums for booting the suggested “FreeBSD-12.1-RELEASE-amd64-mini-memstick.img”, but I bet they would suggest to use another method of installation, burning an optical media perhaps. This would mean I would have to explain that I don’t want to install, but to boot a NomadBSD. And also I bet they would defer me to seek help at NomadBSD which already said

This reminds me of a situation I had two decades ago: AdobeReader alone was taking 10% processor, FireFox alone was taking 15%. But if I clicked a direct link to a pdf document, the processor suddenly went to 78-80% after opening AdobeReader inside a FireFox tab. I wrote first to FireFox and got “not our problem, ask Adobe!” After writing to Adobe, guess what? “Not our problem, Ask Mozilla!” The above quoted reply triggered these unpleasant memories and I don’t want to feel like a ping-pong ball again, so I dropped the matter.

@mirror176: I will check the BIOS to see it’s the last issue, but being a 2009 laptop, age might be more important than BIOS version. But you got it wrong: I NEVER TRIED TO INSTALL ON HDD, T-H-E__P-R-O-B-L-E-M__I-S__T-H-A-T__T-H-E__U-S-B__C-O-P-Y__D-O-E-S__N-O-T__B-O-O-T-!-!-! Although it still boots on the desktop…

@mameko: Before “burning” NomadBSD on this USB stick, I had an EasyBOOT image on it and there were no problems of booting. And I have KNOPPIX with persistence on an identical stick [ADATA C906/8GB] and it’s still working flawlessly.

Just one thought. EasyBoot creates an ISO and Knoppix is an ISO as well. Both work.
As you wrote, the FreeBSD-memstick.img didn’t work. It is an IMG. And NomadeBSD as an IMG too. It is a different file structure and ISO’s are only readable. How did you flashed the content onto you USB?
Only for testing reason: Take a Windows 10 machine and use Win32 Disk Imager (Freeware) or Etcher to flash your USB. Both work very well. And then try to boot your Toshiba again. I believe that it will work.

I used Rufus to flash the stick and it accepted IMG files “by design”. I even noted the different response in interface to the IMG compared to ISO: for the later it had active optiond on HOW to make the media bootable – MBR or UEFI. For the IMG file, all those UI controls were greyed out, as the image has all these “set in stone”.

You forgot one important aspect: It works on another machine of the same era, a desktop computer with a Core2Duo processor.

I might make the test, [stuck in home due to coronavirus anyway – social contacts restrictions, not sick] but I’m sure it will be the same result.

Just a shot in the dark…

Looking at the Toshiba Portege M750 operator’s manual, I see that the bios has:

enable or disable USB Legacy Emulation

enable or disable USB Sleep and Charge function

You might try changing those setting to see if it makes any difference.