SOLVED: Anybody having trouble with Thunderbird?

Did a search and didn’t find anything related.

I cannot seem to get thunderbird to import/sync my data from gmail, yahoo, or any other mail server. The accounts are set up properly via the gui, are authorized by the servers, and show on the left hand sidebar, but will not import my messages. I can send messages, though.

In trying to troubleshoot the issue, I found a bug, which I have reported to Mozilla via their community “support” gui. The bug is this: In the server settings, I get the error message that my storage local directory is invalid; select another. The invalid directory shown in the window is /data/home/user/.thunderbird/…etc. Note that the .thunderbird directory is a hidden directory. The directory in the window cannot be edited in the window. The “browse” application must be used to select another directory…however, the browse application does not show hidden directories. So, I cannot select, by any means, the directory already installed by the thunderbird install scripts, which, on my computer is /home/user/.thunderbird…etc. (I do not have a “data” directory). If I want to make it work, I’m going to have to dig into thunderbird’s configuration files and set it correctly and I’ll likely screw something else up while I’m doing it.

Anyway, I’m not at all sure that’s the reason why thunderbird is not working, so I thought I’d ask if I’m the only one having this issue. I use Thunderbird on Arch Linux and on GhostBSD without any trouble.

A followup question would be: Does anybody use Clawsmail or Sylpheed under NomadBSD?

UPDATE: I finally figured out how to get the Thunderbird “browse” function to show hidden files (duh!). However, it will not allow me to select the directory already created by the install scripts, even though I can see in the directory all my email folders have already been imported. I get the same error message: “The Local Directory path “/home/tony/.thunderbird/r7alciqv.default-release/ImapMail/” is invalid. Please pick a different directory.” Won’t let me select this directory.

Me too. Not so long, a month or two ago. After Gmail improvements to be incompatible with Thunderbird and other open-standards FLOSS. Thunderbird made series of minor updates recently, with no luck so far.

According to rules of the digital cage, independent floss apps are possibly not safe enough, and we should take email from centralized jails only via its WebUI or special closed-code mobile apps in the near future.

It’s a shame we’ve allowed a centralized, monolithic advertising company to obtain a near monopoly on such a great technology.

— Cullum Smith, 2017.

Thanks for that info. My searches weren’t coming up with anything. Thought maybe it was limited to Nomad or FreeBSD only. It’s not just Yahoo and Gmail, but my Roundcube email account is throwing the same error on Thunderbird. It’s strange, though that I can create and send emails out, just can’t import or sync my incoming.

I guess I’ll try Claws and see what it does.

I’m finding it curious that I can send mail, but not receive/sync from my mail servers. I’m also finding it curious that on my Arch Linux box, Thunderbird functions perfectly. I think this is an issue in the FreeBSD pkg of Thunderbird. All my troubleshooting in Thunderbird on my Nomad laptop indicates it is set up properly. I’m going to go through the Thunderbird settings on my Arch box and see what the differences are. Maybe that will tell me something.

“GMail OAUTH2 support impossible” — David Harris, one of the pioneers of internet messaging, netiquette, the author of an excellent mail server “Mercury” and a full-featured MUA “Pegasus Mail”.

Very annoyingly, sites like GMail and Microsoft’s Outlook site have taken to calling OAUTH2 “modern authentication”, as if this somehow marks it as a well-thought-out, balanced mechanism: unfortunately, neither is true.

— David Harris: “Forget the elephants – there’s a donkey in the room!”, 2022.

OK! I fixed my Thunderbird Mail application!

Here’s the problem: On the USB stick, applications are installed to the /data directory. So, when Thunderbird is set up, it installs everything to /data/home/username/.thunderbird. When Nomad is installed from the USB stick to the computer’s SSD or HDD, there is no /data directory. Root is installed to /. All the thunderbird configuration files are there at /home/username/.thunderbird, but when Thunderbird starts looking for its directories, it is still looking for /data/home/username/.thunderbird.

Solution: First, thunderbird must be uninstalled. Secondly delete all configuration files for thunderbird under /home/username/.thunderbird. Third, reinstall thunderbird and reconfigure.

`sudo pkg remove thunderbird`

`sudo rm -r /home/username/.thunderbird`

`sudo pkg install thunderbird`

The uninstall/reinstall thing might not be necessary, but I wanted to start with a clean slate and not risk any config files left over in some directory I don’t know about. After reinstall, I configured my yahoo account and it connected immediately.


1 Like