Octopkg updated 316 packages and broke the desktop

I just updated with Octopkg the mentioned number of packages and when I rebooted, Tint2 is gone, neither the date nor the volume control, nor the network icon.

I ran Tint2 again to set it up again and on reboot it is gone, as is the wallpaper.

Something must have gone wrong, because in any FreeBSD it is not normal to update 316 packages …


Same happened to me, I think it was freeBSD upgrading rather than updating; and the desktop/window manager etc that makes up the Nomad experience is separate from the freeBSD, unlike with a Linux distro where everything is supposed to be aware of everything else. I’m sure the Nomads will address this soon, because it is out of character for things to break by being maintained.
My theory is that with updates, things are fine, but freeBSD must have created an upgrade instead.
So I’m just going to revert back and not let those 316 packages in and await a new Nomad .img with the adjustments to the interface taken care of.

1 Like

Hi Judd. I’m in the same situation, but in mi case the packages updated were 515! To work as usual I must manually run tint2, plank, picom, gxkb, DsbMixer, DsbBatmon, and others. The DSBAutostart does not run, so none of their instructions are executed. It also does not work, for example, the Manage user accounts or Wifi Network Manager, if they are run from the Openbox menu. From what I have been able to verify, the error comes from QT, but I have not located it yet.

1 Like

13th of July and sorry to say to see the same issue here (again!)
Tint and all the rest (bottom menu etc.) gone. Launching via menu key still possible.
Octopkg announces 233 programs to be update but the log shows 373 downloads

I’ll force a complete pkg reinstall and will let you know the result

After experiencing problems with Planck and more after a BIG package update/upgrade last year,
and when seeing the huge number of packages to be upgraded, I went straight to the forum to look for experiences while pkg downloaded the many new packages.
After finding this thread with bad news, I immediately stopped the pkg download/upgrade!
THANKS for posting

See my post from 21. July,


Personally I’ve put this package upgrade on the back-burner for now, unfortunately
There are 2 big chunks caused by Qt and by Python 3.8 - I think

For other users trying to break this upgrade up in chunks, this post on the FreeBSD-forum might help with the python 3.8 part:

NB. this is a script! :wink:

Following procedures may ease the upgrade:

For users of pre-build packages:
# sh
# for i in $(pkg query -g %n ‘py37-*’); do pkg set -yn ${i}:py38-${i#py37-}; done
# pkg upgrade

sudo pkgupdate
sudo pkgupgrade -f
reinstalled 959 pkg items, same symptoms
Having now 15 packages py37-* installed with 39 py38-*

I can now agree that Python 3.8 is the problem;
Especially after reading ‘python38-3.8.9 is broke and I’m waiting to fix it:’ here:

(N.B.the upgrade was done to python38-3.8.10)

Am I allowed to rant about the programming language named after “a British surreal comedy troupe” now? I did not plan to go into extra work this evening/week :
Checking integrity…

  • openexr-3.0.5 conflicts with ilmbase-2.5.7 on /usr/local/include/OpenEXR/Iex.h
  • libglvnd-1.3.3 conflicts with mesa-libs-20.2.3 on /usr/local/include/EGL/egl.h
  • py38-cairo-1.18.1_1,1 conflicts with py37-cairo-1.18.1_1,1 on /usr/local/include/pycairo/py3cairo.h
  • py38-markdown-3.3.4 conflicts with py37-markdown-2.6.11_1 on /usr/local/bin/markdown_py
  • Imath-3.0.5 conflicts with ilmbase-2.5.7 on /usr/local/lib/libImath.so
  • py38-qt5-core-5.15.4 conflicts with py37-qt5-core-5.15.4 on /usr/local/bin/pyuic5
  • py38-sip-5.5.0_1,1 conflicts with py37-sip-5.5.0_1,1 on /usr/local/bin/sip-build
    Conflicts with the existing packages have been found.
    One more solver iteration is needed to resolve them.
    The following 373 package(s) will be affected (of 0 checked):
    Installed packages to be REMOVED:
    ilmbase: 2.5.7
    py37-cairo: 1.18.1_1,1
    py37-gobject3: 3.38.0
    py37-markdown: 2.6.11_1
    py37-qt5-core: 5.15.4
    py37-qt5-gui: 5.15.4
    py37-qt5-widgets: 5.15.4
    py37-qt5-xml: 5.15.4
    py37-sip: 5.5.0_1,1
    Number of packages to be removed: 9
    Number of packages to be upgraded: 232
    Number of packages to be reinstalled: 70


I have the same symptoms as you.

At the moment I’m starting tint2 to use NomadBSD partially.

I have been using NomadBSD for several months for my work and I am very happy with it.

If Python 3.8 is the problem, what is the solution (wait for an update? reinstall everything?)


  1. the DSP/autostart.sh does nothing for the primary user (the one that runs octopkg)
  2. the 2 other users defined on my machine work with a desktop functioning as expected…
  3. experimenting from the command line I see that DSP/autostart.sh will need to be updated in the future :slight_smile:
    mpe@NomadBSD ~> compton
    [ 15-07-2021 12:25:52.982 session_init WARN ] This compositor has been renamed to “picom”, the “compton” binary will not be installed in the future

I reinstall NomadBSD-130R, before update (pkg upgrade), I do:
for i in $(pkg query -g %n ‘py37-*’); do pkg set -yn ${i}:py38-${i#py37-}; done
pkg upgrade

It works for me (while waiting for better)

Hi all. I think I have found the solution to this issue. I’ve copied the content of the file $HOME/.config/DSB/autostart.sh to the file $HOME/.config/openbox/autostart.sh and now my system start starts with normality and loads all the programs that I have defined in DSBAutostart. I hope this solution serves everyone.

1 Like

The suggested solution is to add the command “sh ~/.config/DSB/autostart.sh&” to the file “~/.config/openbox/autostart.sh”.
Source: https://cgit.freebsd.org/ports/tree/x11/dsbautostart/pkg-message

1 Like

Same issue here, the update broke my desktop. Thanks for the suggested solution, but it does not work for me, because there is no file ~/.config/DSB/autostart.sh on my system any longer. Can someone please post the contents of this file. Thanks.

Hi Gulliver. This is the content of my file autostart.sh:

dsbmc -i&
sudo -E networkmgr&
redshift -l$(getlalo)&
daemon -f update_obmenu -a -p 5&
dsbmixer -i&
/usr/local/libexec/at-spi-bus-launcher --launch-inmediately&#!/bin/sh

I had this same problem. Creating the autostart file in ~ /.config/openbox/ with the content you posted was the solution, thank you so much :grinning:

DSBAutostart creates desktop files for autostarting programs. The desktop files are read and executed by a script which is part of Openbox. This script uses the Python module py37-xdg (now py38-xdg). Due to the Python upgrade you have to install py38-xdg:

# pkg install py38-xdg

Using ~/.config/DSB/autostart.sh is deprecated, and DSBAutostart will ignore that file when editing the autostart list.

1 Like

The 130R-20210508 Errata was updated.

1 Like

pkg install py38-xdg ↓

Thank you for the explanation and subsequent solution. :ok_hand:

Everything went back to normal.

Hi. Following the instructions of the errata file has revived my GUI. Thank you all for your support.

1 Like

In my case, installing py38-xdg has not been the solution, it has made it worse, and I have had to uninstall it, since it prevented the ~ / .config / openbox / autostart.sh commands from being executed and the GUI did not it worked correctly.