NomadBSD does not autodetect NVIDIA gpu [SOLVED]

I ran the USB install and then installed the system to my HDD; I did not see the autodetect graphics card option and I’m stuck on vesa mode, 1024x768

System specs:

  • AMD FX-6350 CPU
  • 16GB RAM
  • Corsair 1TB SSD
  • WD Black 4TB storage hard drive (NTFS)
  • nvidia GTX 1050 ti

pciconf -lv | grep -B3 display

vgapci0@pci0:1:0:0: class=0x030000 rev=0xa1 hdr=0x00 vendor=0x10de device=0x1c82 subvendor=0x1458 subdevice=0x3746
vendor = ‘NVIDIA Corporation’
device = ‘GP107 [GeForce GTX 1050 Ti]’
class = display

sysctl -n hw.pci.default_vgapci_unit


I cannot find a command to run the script, I’ve searched online, the Handbook and tried using autocomplete on the command line; I probably just looked over it.

Any help or suggestions will be highly appreciated.

I ran:

pkg install x11/nvidia-driver x11/nvidia-settings

Which gave me an e2fsprogs error

pkg upgrade: e2fsprogs-nobootfsck-1.46.4_1 conflicts with e2fsprogs-1.46.2

So, I followed the errata and rebooted. I now have the nvidia drivers installed.

1 Like