NomadBSD 1.3.1 USB install boots on BIOS computer, but HDD install does not boot

TL;DR: Nomad Installer doesn’t make HDD install bootable on BIOS-based computers. I think it is not creating MBR partition scheme, or something that prevents non-UEFI BIOS to boot it.

Long story:

Hi and thanks for this amazing FreeBSD derivative!

I am a Windows user trying to make the first steps switching from a closed source OS to an open source by installing on a 2006 laptop that came with Windows Vista Home Premium.

My previous experience with *BSD was trying to make NetBSD boot to X (it freezed after showing the default twm environment) and I could make FreeBSD compile X, Lumina Desktop, Mozilla Firefox, Mozilla Thunderbird and LibreOffice. I felt like a child who just started riding a bike for the first time without the little auxiliary wheels! I didn’t settle with this setup as I could not make Lumina Desktop stay on Brazilian Portuguese, it always changed back to English after every login.

I could try and even use NomadBSD 1.3.1 installed on my USB flash drive. It was great, 95% of my dream desktop environment pre-built, no need to wait days compiling or hours downloading from the Internet (not that I wouldn’t do a rebuild from source to make sure only things I needed was compiled and custom built to my CPU). It’s not 100% of my dream desktop environment because it was not Lumina Desktop, but, hey, I can live with that!

Unfortunately, I could not make it boot from the internal HDD. Nomad Installer makes the partitions, copy the files, but somehow it does not boot. I even tried to use the “Lenovo fix”, to no avail.

My laptop is BIOS based (no UEFI), 2GB RAM with Intel Pentium Dual Core. I tried to do the HDD install with both the 32 bits and the 64 bits images. My BIOS try to boot from the HDD first, then from USB drives, then from CD-ROM drive, and lastly from the network card. When I reboot and remove the USB where NomadBSD is installed, it just try to boot from the network card.

All other systems I tried booted from this machine. I tried NetBSD (it booted to console, I could not make X work), FreeBSD (I could compile X and Lumina Desktop by following the FreeBSD Handbook), Haiku (I did the partitioning and formatting of the BeFS by hand a the GUI had a button to start the partition editor), Linux Mint (I did a custom partitioning to create the swap partition instead of using a swap file), Elementary OS, Zorin OS, Endless OS, ReactOS (partitioned and formatted as Btrfs), so I can handle things pretty well if they are graphical and are on a menu or a button on my face to be discoverable. My difficulties are with command line tools, as they aren’t so “in your face”. Sorry for being such a WIMP (Windows, Icon, Mouse, Pointer) person. I need instructions to use the command line.

In my defense, I can handle the Windows Command Prompt very well (I grew on the MS-DOS and Windows 3.1 era) to the point of creating install scripts for .MSI packages and .EXE installers, and can build simple install scripts even on Windows PowerShell to customize what is possible on Windows 10 after a new install (change DNS servers, remove built-in UWP applications and OS features, add Registry Settings, disable or enable System Restore, install all my favorite software). Heh, maybe I am WIMP only on non-Windows OSes…

Could someone please help me how to make NomadBSD install to my HDD? I think the problem may be Nomad Installer is using GPT instead of MBR partition scheme and my computer BIOS can’t see it.

Not sure I can help, but I do have a bootable 1.3.1 on a 1GB hard drive. Now, this is an external HD with ONLY NomadBSD on it. Booting is simply a matter of F10 to get the BOOT menu up from the BIOS, selecting that HD and go!

I’m not sure if this helps you but if you have an external HD do, try that. It may be that NomadBSD will not boot from a PARTITION for older (pre UEFI) BIOS’s.

Good luck!

Can you explain in more detail how you installed NomadBSD on your notebook computer’s hard drive? Also, it is a good idea to post the details of your hardware. (What make and model of laptop, etc.)

I installed NomadBSD on an old Dell D530 (No UEFI) and had no problems with it. So, I don’t think non-UEFI bios is a problem in and of itself.

Iam also experiencing the same problem. My disks are pre formated as GPT and my bios is legacy. I will delete the disk and format it as MBR. Maybe this will install nomad. I think the command to format MBR is gpart create -s mbr ada(x)

I can not help to fix your problem but just for going the short way, you can use an USB stick with Supergrub It scans your hd and find nearly every OS - and just boots it.
I hope you can fix your boot problem.
Reformatting GPT to MBR could be a chance.

I had that problem too. But I changed the file format from UFS to ZFS and no problem.


dd bs=4M if=NomadBSD_X.iso of=/dev/adaX

Just a little update : Manage to have a working os booting from hard disk. The issue in my case is the crappy AMD ahci controller and it is Asus bios related (also experienced problems under windows and other distros). I edited /boot/device.hints/ and added these lines :


So not giving me CAM Status errors…

1 Like