Nomad on Dell Latitude E5570 - It Works!

I decided to give NomadBSD a try on my new-to-me Dell Latitude E5570. I am pleased to report that it works very well! Installing onto the hard drive was easy, and most of the system hardware works out of the box. Overall I’m very pleased with how it is working, and with just a few tweaks have been able to make things really work well. There are a few things I haven’t been able get working right, but, with one exception, I am confident that it won’t hinder me from using this laptop in any way. Below is a summary of what worked, what doesn’t work, and what I have done to make things work. I’m sure there are some things I could test that I haven’t thought of, so if there is something you’d like me to test, just ask!

Without any additional configuration, here’s what worked out of the box:
Touch pad with 2 finger scroll
Intel accelerated graphics
Intel 8260 Wi-Fi
Webcam and built-in microphone
Multi-monitor setup
automounting of USB drives
Suspend and Resume using the Leave Menu

With just the addition of one setting in /etc/sysctl.conf I was able to get suspend to work when closing the lid.

The discreet AMD R7 M370 appears to work, but I would have to manually setup to load in rc.conf rather than the initgfx. As right now I’d rather have the battery life using the Intel graphics, I’ll not mess with that.

Running “pciconf -lv” showed six devices without drivers. I was able to locate one in the base system, the Intel SMBUS controller, which loads fine after I added the line in loader.conf. The others are the SD card reader and chipset drivers relating to Intel Thermal system and power management. The SD card reader may be a lost hope, as there are no FreeBSD drivers I have found for this particular card.

The bluetooth adapter bundled with the Wi-Fi card was giving a “firmware not downloaded” error in DMESG. I was able to install from packages /comms/iwmb-firmware, and it now loads fine. I don’t use bluetoooth, so I can’t verify right now if it works.

I haven’t tested the fingerprint reader yet. Not sure what programs or setup is needed to use that.

The multi-media keys do not work. I’ll have to research that some. Not a big deal to me.

I haven’t been able to test out the Ethernet yet. It would be nice to have an option with the Wi-Fi manager to clearly switch over from Wi-Fi to Ethernet. I’ll play around and see what I can do.

1 Like

Add it to or