Nomad 14 broken before updating


I am a new user to BSD and have tried Nomad 3 times since July 2021 and it broke on update each time - none of the errata fixes worked.

A fresh install of Nomad 14 is broken before updating - no power management, updates error “fail to create hardlink”, and looks like there is a problem with Python and QT.

With the code suggested in errata:

"On the amd64 and the mac image run:

fetch -o /tmp/hlp.tar.gz

tar -C / -xf /tmp/hlp.tar.gz


It now boots to a tty screen login.

Is there a fix for this?

Thank you.

Hi @recj,

if I understand your problem correctly:

log in as root and run pkg upgrade to complete the upgrade, then reboot.

1 Like

Continuing the discussion from Nomad 14 broken before updating:


Thank you for your reply!

I erased the drive that booted to the ttyvo screen, thinking it might be only for virtualbox, but had 2 more live-usb flash drives with it fully configured.

I applied the same fix on one of them and there was a different result.

When I hit “reboot” it went to console screen loading(?) a lot of entries, mostly starting with “usb”. [please see attached]

After 3 hours, and the end nowhere in sight, my T450s ThinkPad was getting a little hot, so I powered off.

The same error still appeared in Octopkg, but installed the 18 updates anyway. All went well,
but still no part of power management works.

As beautiful and well put together Nomad is, it might not work with everyone’s hardware.

If power management was fixed, would manual or auto-suspend work on the live-usb or external HDD disk? - or it would it need to be installed internally on an HDD?