New Install - Automount and Network Mngr icon, won't come out to play

Hi All,

New Nomader keen on learning this “new way”, Going through the initial learning curve.
Not fun, but has to be done.

Having two issues currently:

1 - trying to get a thumbdrive with FAT32 to automount.
When I click on System > DSBMC in the application menu, the DSBMC icon is shy and doesn’t seem to want to show up on the task bar.
Read the Nomad handbook and tried entering the command dsbmc-cli -a in Sakura. This was the result:

dsbmc: illegal option --c
Usage: dsbmc [-ih] [<disk image> ...]
	-i: Start dsbmc as tray icon

Mmm, k.
Watched a recent(ish) video by Robonuggie re/ system tweaks and installing a pkg called automount (about the 35:50 min mark).
That was on a FBSD install. Would that be worth trying, or should this be working in Nomad without resorting to that? Would it disrupt anything in Nomad’s settings or conf files?

Checked OctoPkg, and I see that Fuse is installed, so if I can get the auto-mount (or even manual mount) working, it should recognize, open and work with a FAT32 drive - yes / no?

2 - in the task tray icon for Network Manager, the options for Wired Connection and Ethernet are greyed out and unavailable. I do have an internet connection though.
Are these inactive for some reason? Are there configurable options here that should be available?

Currently testing this with a 16 GB drive (USB 2.0) drive on a system w/ 3GB Ram, Intel duoCore and nvidia card.
Current NBSD release (140R-20240126) using ZFS.
A bit laggy, but working fine so far except for a few things.

Look forward to any suggestions, insight & tips you can provide.

You can install networkmgr so that the network icon works and is not greyed out pkg install networkmgr.

With 3 GB of Ram it will run slow, it can’t wait any longer, maybe using UFS it can go a bit faster than with ZFS.

I’m not a BSD guru, just my experience, hope it helps!

You have an old machine, so I suggest you try 132R-20231013 because it uses Openbox (which is lighter than Xfce).
Also, on the whole, on a USB stick, UFS is likely to do better than ZFS.

Hey Judd, thanks for the suggestions.

Re/ the lag w/ 3 GB and ZFS, knew that would be the case going in, but I like the benefits that ZFS brings. And a bit of lag is fine for now. That being said, I’m now testing on another system with 8 GB. Still a touch of lag (USB 2 or 2.1 drive), but it’s workable. If I can get a base system working with a few needed apps, I’ll be happy and move to a better USB drive.

Re/ “networkmngr”, this was one of the 456 updates that are needed (see further below).

Installed packages to be UPGRADED:
	networkmgr: 6.2 -> 6.4

Number of packages to be upgraded: 1

Proceed with this action? [y/N]: y
[1/1] Upgrading networkmgr from 6.2 to 6.4...
[1/1] Extracting networkmgr-6.4: 100%
networkmgr-6.2: missing file /usr/local/bin/netcardmgr
==> Running trigger: gtk-update-icon-cache.ucl
Generating GTK icon cache for /usr/local/share/icons/hicolor

And … icons are still greyed out and unavailable.

As noted, am now testing it on a new system with an Intel i5 and 8GB Ram. Well, newER anyway. :wink:
OS: FreeBSD 14.0-RELEASE-p4 amd64
Packages: 937 (pkg)
DE: Xfce 4.18
WM: Xfwm4
CPU: Intel i5

Still not showing DSBMC when clicked / activated.
And the “Network Mngr” options are still greyed out.

Ethernet Network (nada)
Wired 1 Connected (nada)
Disable (available, but that would defeat the purpose)
Close Network Manager (available)

Ok, maybe updates are needed. Checked OctoPkg and it said 456 updates were available.
Great! Maybe that will help. Selected the “Install Updates” icon and waited over an hour while it downloaded over 1 GB of files. And then extracted and started to install them. And then an error happened a few minutes later. Tried again.
And then another hiccup:

Installing updates...

Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Checking integrity... done (1 conflicting)
- polkit-qt-1-qt5-0.200.0 conflicts with polkit-qt-1-0.114.0 on /usr/local/include/polkit-qt5-1/PolkitQt1/ActionDescription
 done (0 conflicting)
The following 436 package(s) will be affected (of 0 checked):
Installed packages to be REMOVED: 
polkit-qt-1: 0.114.0
New packages to be INSTALLED:
gcc13: 13.2.0_4
jq: 1.7.1
oniguruma: 6.9.9
polkit-qt-1-qt5: 0.200.0
py39-socksio: 1.0.0
wx32-gtk3: 3.2.4_1
xclip: 0.13.82_1
Installed packages to be UPGRADED:
Imath: 3.1.9 -> 3.1.11


xxhash: 0.8.2 -> 0.8.2_1
zenity: 3.42.1_2 -> 3.42.1_3
zip: 3.0_1 -> 3.0_2
zsh: 5.9_3 -> 5.9_4
Installed packages to be REINSTALLED:
Number of packages to be removed: 1
Number of packages to be installed: 7
Number of packages to be upgraded: 426
Number of packages to be reinstalled: 2
[1/436] Upgrading libdeflate from 1.19 to 1.20...
pkg: Fail to create hardlink: /usr/local/bin/.pkgtemp.libdeflate-gunzip.Pxz1f10uOC6P /usr/local/bin/.pkgtemp.libdeflate-gzip.HMJBMG2BsUdw:File exists
[1/436] Extracting libdeflate-1.20...

Command finished with errors!

Should I just select all others except the “lifdeflate” and try again?

Just before that, I searched for and installed Iridium browser.
Launched and configured it. No issues.

Then also tried CherryTree. Downloaded and installed it along with its dependencies no problem. But … launching it has the same result as trying to launch DSBMC. Nada.
It shows green in OctoPkg as being installed. But the program “fails to launch”.
Is this common for applications that are available straight from the repository?

This is a base install of the current release with nothing done to date except a few cosmetic configurations to the desktop.

But so far: no DSBMC (needed), no Network Mngr options (would be nice), no CherryTree (also need this one), and aborted updates.

Soooo … now what? What are some other things I can try to get these few basics working?

As a personal rule I always install applications after a full system update, never before…
Try to update it completely if that’s possible, on my side everything works.
Regarding the applications that you installed and that don’t open, I don’t really use them, I don’t know them. Except for iridium which I installed once and haven’t used again, I only use Firefox.
Otherwise, I hope someone else on the forum can help you or I think there are people on the Telegram channel who can.

PS: Select all the packages that OctoPkg pulls, it’s always good to do that.

Hi judd and gmacar,

Sorry for the delayed reply. Tried some roll backs to earlier Boot Environments - still getting the same results plus a few other quirky things, and the update process still halts early into the installs phase. (Yes, was opting for all updates that OptoPkg had listed.)

At this point, I’ll probably start from scratch with a clean install (then enable the firewall and run the updates.) … see if that does the trick. Thanks for the tips and suggestions though, much appreciated.

As @Ime says you have to watch out for a new download that will be released in these days due to errors in the current one, in my case for amd64 it would be nomadbsd-141R-20240616.amd64.zfs.img.lzma 2024-06-18 17:57 2.3G in the NomasBSD download site → Index of /download