New Dell Laptop, won't install Nomad

Hello !

A few days ago I bought a Dell inspiron 5593 laptop with Nvidia MX-230, a 10 generation i5 and Win10 installed.
(I am no longer interested in Win10, Dell Assistant and all that. I want to delete everything.)

All this is just to say, I can’t install Nomad or FBSD.
I have tried everything possible and there is no way, from reinstalling win10, and that way I thought I could install the BSD. I also shrunk the C: partition and disabled Security Boot, I couldn’t either.

Conclusion, I always get the installer, both Nomad/FBSD only as read and not as write, that is, I can always install on the USB/Pendrive, but not on the laptop disk. That is, it doesn’t let me see the hard disk partitions, it only takes the usb disk to install/write on it.

To better understand what I want to explain, since the language barrier sometimes prevents me from doing so, I leave a screenshot so that you can see better what happens when you want to install BSD on the hard disk and not on the usb/pendrive.

For this reason, I ask what I can do…?..

Thanks as always!

I found that to install the 32bit version on one of my laptops, that I had to create a new boot sector (& partition/slice) before NomadBSD would ‘see’ my hard drive - note that doing so will overwrite what is on your hard drive - so think carefully before doing this!

It may, or may not work for your computer - your decision. :wink:

Hi @Camtaf!

Thanks for answering.

Let’s see, if I got your message, create a new boot sector before Nomad sees my hard drive partitions.
Yes, this can be done, because I have seen it in the Bios/UEFI (does not support Legacy, unfortunately …) of the laptop, also this sector does not carry a volume of megabytes, it is only an order, is it?

I’m used to using Linux more than BSD, & my system was BIOS, I just gave it a new MBR, partitioned the drive, then Nomad installed.

UEFI uses GPT, so I guess you will need to figure out how to set up your disk for it, I only have 2 UEFI machines, one of which I used as a normal UEFI, which worked straight off, the other I installed as MBR, fiddled with the boot option somehow, can’t remember exactly what.

By the way, you should use sudo fdisk /dev/ad0 I think.

Yes, I’ve tried several tests so far, I’ve even erased the entire disk ↓


thinking that it might give me some option to see the partitions, when I want to install other operating systems. This was not the case.

He is right.

Thank you very much for your attention and time.

If it is an NVME, it is likely to be /dev/mmcblk0 not /dev/ad0 (which is a regular hard drive).

What does sysctl kern.disks say?

Good morning!

@Camtaf @mk1

Sorry I have to post pictures, I don’t have a nomad connection, the card in this machine is a Qualcomm and the driver is not there yet.
I inserted a Nisuta → rtwn0 wifi dongle and I can’t connect …

From your post, your disk is actually /dev/da0 - that is usually a USB designation - but now fdisk should work.

Re the wifi, it needs to be present when booting up, & the system should load the required driver software; then you need to configure it to your network.

For some reason, your HDD/SSD/NVME is not supported. There nothing we could do about it. The devs on the FreeBSD ML might be interested. What do dmesg | egrep -i 'nvme|nvd|ada|da' and pciconf -lv | grep -B3 storage say?

1 Like

@mk1

The devs on the FreeBSD ML might be interested.

If you have access to them, it would be very important for me and I would be very grateful.
It is a nice challenge for those who are into these subjects, a bit complicated for people like me (self-taught, that’s all.)

If, as you can see, nvme is not supported, I will exchange it for a regular ssd disk, as I am NOT interested in warranty or anything like that.

From your post, your disk is actually /dev/da0 - that is usually a USB designation - but now fdisk should work.

fdisk doesn’t work here and I don’t know why.

Re the wifi, it needs to be present when booting up, & the system should load the required driver software; then you need to configure it to your network.

Regarding the connection, it doesn’t take the Qualcom card.

This is very interesting → https://lists.freebsd.org/pipermail/freebsd-questions/2020-September/291578.html

I forgot that the flash drive is 32GB …I saw so many gigabytes that I was happy. :smile:

Well, this laptop has the possibility to install Ubuntu and so I did. (less Win, always better :))
I installed it with experimental ZFS, according to the installation guide.

judd@judd-Inspiron-5593:~$ lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0         7:0    0  55,5M  1 loop /snap/core18/1988
loop1         7:1    0    51M  1 loop /snap/snap-store/518
loop2         7:2    0  64,8M  1 loop /snap/gtk-common-themes/1514
loop3         7:3    0   219M  1 loop /snap/gnome-3-34-1804/66
loop4         7:4    0  31,1M  1 loop /snap/snapd/11036
nvme0n1     259:0    0 238,5G  0 disk 
├─nvme0n1p1 259:1    0   512M  0 part /boot/efi
├─nvme0n1p2 259:2    0     2G  0 part [SWAP]
├─nvme0n1p3 259:3    0     2G  0 part 
└─nvme0n1p4 259:4    0   234G  0 part 
judd@judd-Inspiron-5593:~$ 
judd@judd-Inspiron-5593:~$ sudo parted --list
Modelo: PM991 NVMe Samsung 256GB (nvme)
Disco /dev/nvme0n1: 256GB
Tamaño de sector (lógico/físico): 512B/512B
Tabla de particiones: gpt
Indicadores de disco: 

Numero  Inicio  Fin     Tamaño  Sistema de archivos  Nombre                Banderas
 1      1049kB  538MB   537MB   fat32                EFI System Partition  arranque, esp
 2      538MB   2685MB  2147MB  linux-swap(v1)                             swap
 3      2685MB  4833MB  2147MB
 4      4833MB  256GB   251GB   zfs

One more step to see if I can install Nomad, as it now takes the partition table.

Modelo: SanDisk Cruzer Blade (scsi)
Disco /dev/sda: 30,8GB
Tamaño de sector (lógico/físico): 512B/512B
Tabla de particiones: msdos
Indicadores de disco: 

Numero  Inicio  Fin     Tamaño  Tipo     Sistema de archivos  Banderas
 1      1049kB  43,0MB  41,9MB  primary  fat32                esp
 2      43,0MB  3758MB  3715MB  primary                       arranque
 3      3758MB  30,8GB  27,0GB  primary

One thing to add here: Please don’t use fdisk. Use gpart instead.

1 Like

Thanks for the advice, I will do so from now on!

For future reference, gpart show:

  • shows information about partitions
  • does not show devices that have no partition.

https://forums.FreeBSD.org/threads/81418/post-523833