NBSD 14.0 forced gui login not accessing to desktop

Hi all, I’ve been experiencing with much satisfaction NomadBSD since 1.3 release.
Now just burned a USB stick with the the latest 14.0, and system works/performs fine.
A very annoying problem comes when from there I set the installation onto another volume (different USB stick) creating the specific user, with ZFS and autologin parameters on the target. When the installation is complete and I reboot from the new volume, most of the times it lands me in the gui user login but no way to get to the desktop like the password was wrong, while it’s absolutely the right one. After click on the “go” gadget, it turns in the black terminal prompt for less than a second and returns on the gui user login screen, and so on same result. To succeed in a direct access to the desktop I have to reboot also 3-4 times. Very annoying.
Any suggestions?
Thank you much

When it cuts to the black terminal prompt is there any text on it? I know you said it cuts to it really quick but maybe try taking a video and pausing it at the time it cuts to the black screen, if there is text, so we can see if there are any error messages.


thank you for answering. Here are the screenshots:
1-gui login , put my password and then “go” (click on triangle gadget)
2-lines appearing for less than half second before to return at gui login. Note, those lines are same as the ones at the end of verbose boot, just before the first time gui login screen

No problem. I remember what it was like running into issues and getting stuck without help.

Have you tried logging in as root in the login screen? Curious if the same issue happens there. Also, at the login prompt, on the command line, does it allow you to log in as the user? If so can you do that and try running startx to see if it brings up a desktop? If it doesn’t allow you to log in as the user but will allow you to log in as the root user maybe try changing the user password and attempting to log in again.

Sorry for all the questions. Just trying to find out what the real problem is.

ok, first I tried to input the user login at the prompt request moment, the thing is that it does not take any input at that time, it just run automatically to the next step while I was trying to write the username.
The good new is that the automatic login worked well in this case and I could access to desktop directly. So gave the “shutdown” and I could boot successfully again.
After that tried again, and it worked well again.
Tried other 20 times consecutively, no problem in all cases.
Then tried with “reboot” command 5 times, worked well again.
Then again 3 times with shutdown-boot , no problem.
It seems solved itself, with no appearent reason.
Thank you by now.

You’re welcome. Glad it’s working. If there’s any other problems let me know.