Mounting USB

Trying to find USB pen drive.
Tried going to applications and opening DSBMC
‘Fatal error: uconnect(/var/run/dsbmd.socket): Error: connect(/var/run/dsbmd.socket): Connection refused’
from command line tried and getting exactly the same.
Following something on a freeBSD forum i managed to get the drive up but itś a bit of a drag doing it and then ejecting from the command line. DSBMC looks like the thing for numpty like me, how to fix?

Hi @gbar,

for some reason dsbmd (the daemon DSBMC is connecting to) is not running. What does grep dsbmd /etc/rc.conf say? Try to start it manually via service dsbmd onestart, and check if there any messages regarding dsbmd in dmesg: dmesg | grep dsbmd.


So far, so good. What happens if you run /usr/local/libexec/dsbmd -f (as root)?

dsbmd: dsbmd started on Thu Jul 30 19:44:01 2020
dsbmd: ioctl(/dev/cd0, CDRIOCREADSPEED): Device not configured on Thu Jul 30 19:44:02 2020

Looks good. Now, start DSBMC and then try to mount your USB pend drive, and see what’s happening at the console where you started dsbmd -f.

its working now!

computer restarted (?) and now on the top of the screen i see the little USB sign.

Mounts and ejects like a charm.


and then…today…
‘lost connections with dsbmc’ or something similar no longer connects

For some reason dsbmd crashes or quits due to a fatal error. That requires some debugging. It’s not the best solution, but if DSBMC loses its connection to dsbmd, run service dsbmd start as root, and then start DSBMC again.

Could you please post the content of /var/log/dsbmd.log here if that error happens again? Make sure to save the log file in your home directory, because files under /var/log do not survive reboots.

great thanks.
Could you please post the content of /var/log/dsbmd.log here if that error happens again? sure, no problems.
wouldn’t be surprised if its a hardware issue, oldish inherited compooter