Macbook Air 2017 : Need Help With Proprietary Firmware/Driver

Details :
Device : MacBook Air (13-inch, 2017)
Card : Broadcom 4360 , PCI-ID : 14e4:43a0
Driver I used on Linux (Ubuntu, Arch) : bcmwl-kernel-source
Linux Driver Reliability : Complete, Unfailing
OS : NomadBSD FreeBSD 13.0-RELEASE-p3, GENERIC kernel, amd64 base).

So basically I need to do what bcmwl-kernel-source did for me when I used to use Linux.

I have posted this to FreeBSD Forums too, see here.

Progress :

  • I’ve been informed that there’s bwn for “modern” broadcom chips, but it does not in fact cover the bcm 4360, so I’m better off using a USB wifi dongle.
  • I’ve thus tried to get a dongle to work. Even that is failing. I know the dongle to be have Realtek chips, and so used the rsu driver (though I also tried the run driver just in case - and of course it didn’t work). TL;DR is basically :
$ sudo kldload if_rsu rsu-rtl8712fw
$ sudo ifconfig wlan0 create wlandev rsu0
ifconfig: SIOCIFCREATE2: Device not configured 
  • The same error comes up wether trying to use bwn or run. The device is never configured, apparently.
  • So my macbook’s bcm4360 doesn’t work, and that’s totally understandable , it’s propietary drivers+firmware, but astonishingly (it seems to me that FreeBSD is supposed to only be used with an ethernet cable in hand ?) even the suggested most compatible option of a USB dongle has 0 success.
  • My macbook has no ethernet port. What is one to do ?
  • The prvious FreeBSD Forum thread is cluttered, and the problem has evolved completely from trying to use bcm4640 to a Realtek USB adapter. Hence refer new thread(https :// for new details (kldstat, usbconfig, pciconf -lv, rc.conf, loader.conf).
  • UPDATE : Realtek makes a windows utility that tells me that the chipset is RTL8188FTV . tells me(https :// that it’s not supported …

Nice to see you’ve got the help you needed over at the FreeBSD-forum.
Hopefully third time’s a charm regarding wifi-chipset…
With this post you’re not totally ignored here on the NomadBSD-forum :wink:

Personally I’ve had success using different models of ultra cheap “Sempre” USB-wlan-adapters under FreeBSD