Issues Asus Tuf Gaming 705gm Laptop

My Asus TUF Gaming 705GM is 1 year old. Most of NomadBSD is working out of the box and pretty well. I found some minor issues and perhaps one can help me.

  1. The touchpad is not working. Neither with USB mouse nor without it.
    I did not install any software for that because I know that NomadBSD as a life system boots most of the things automatically.
    OctoPkg shows 3 entries for synaptic and 1 is installed.
    synaptics
    So usually the touchpad should work. What can I do?

  2. I have an Intel graphics and a Nvidia graphics device. Automatically only the Intel device is used from NomadBSD. I installed the Nvidia driver from OctoPkg but even after a reboot only the Intel device is used.

     $: pciconf -lv | grep -B3 display
     vgapci1@pci0:0:2:0:	class=0x030000 card=0x1b4e1043 chip=0x3e9b8086 rev=0x00 hdr=0x00
         vendor     = 'Intel Corporation'
         device     = 'UHD Graphics 630 (Mobile)'
         class      = display
     vgapci0@pci0:1:0:0:	class=0x030000 card=0x1b4e1043 chip=0x1c2010de rev=0xa1 hdr=0x00
         vendor     = 'NVIDIA Corporation'
         device     = 'GP106M [GeForce GTX 1060 Mobile]'
         class      = display
    
     $ nvidia-settings
     ERROR: NVIDIA driver is not loaded
    

How can I load the driver?

You could always manually load the driver using kldload. If you want to use the switchable graphics, where you only use the Nvidia graphics when you need the power, there has been some work being discussed on the FreeBSD forums here: https://forums.freebsd.org/threads/nvidia-optimus-driver-for-freebsd.71504/

My laptop has AMD graphics, and it would be nice to know how to make NomadBSD’s autodetection pick it up.

1 Like

Thanks @jardows
Now I try to figure out how to get the Touchpad working.

Different Nvidia drivers are already available in NomadBSD. The scripts for finding the best video driver will only look for the default video adapter, which is in your case the Intel IGPU. You could either consult your BIOS/EFI to enable the NVIDIA (and disable the Intel IGPU) or, if the latter doesn’t work, you could try the following:

Boot NomadBSD, and then enter the loader prompt by pressing 3 at the boot menu. At the loader prompt type:

 set hw.pci.default_vgapci_unit=0
 boot

I got the Nvidia driver working, but then the sound was gone.
If I use the default Intel graphics device, sound is working fine.
Strange. I don’t like to play games with NomadBSD, so I just use the Intel card and enjoy the sound. Thanks, @mk1

By loading the Nvidia driver, the integrated sound devices of your graphics card appear. Therefore, the default audio device unit doesn’t match your sound card anymore. But you can easily correct that

I let the laptop run with the default Intel driver, which works fine. For gaming I even reboot into Windows 10.
Nearly everything is working now in NomadBSD.
For my Intel Wireless AC 9560 I just have to wait till FreeBSD 13 and then it will work.
At last my touchpad doesn’t work. But that’s a minor issue. I use a mouse instead and all is done.
I’m happy that NomadBSD is working so nice on an actual machine. I use it for my daily work. It runs very stable and fast.

1 Like