Image Extraction Error

I have tried extracting the 1.3.2 archive 10 times now, and it’s always failing at 99%. I even tried to write the image left-over to my USB and to boot from BIOS, but it didn’t start (obviously). I got it from the Indian Mirror if that helps.

Hi there @BK_Jena,

your image was not completely downloaded. According to your screenshot the size of the compressed image is 1564 MiB, but it should be ~ 2606 MiB (2733098747 Bytes).

These are the actual sizes. You can see the archive size is accurate, the extracted image is smaller for some reason. It always shows the error like in the first screenshot.

Edit - I tried extracting it again, and the total size like in the first picture is not 1564 MiB, but 2014 MiB. There was a new value the 3rd time I tried just now. Same error everytime, but the total size in the extraction box differs every single time.

Is the sha256 checksum of the compressed image correct? Do you have enough free space on your HDD? If both is true, try to use a different extraction software.

I just tried using Peazip for windows. The extraction was stopped automatically at around 60% due to “archive corruption”. Is it possible that the Indian mirror file is corrupted? Or do they all fetch the same file from a single location?

I used this website to check the SHA256 checksum and I got this result -

On the website for the indian mirror, it says the checksum should be this -

Even though the size is 100% correct to the last byte, the checksum is different. Is the website not reliable? I couldn’t find a way to find the checksum in any other way on windows. The CMD command did nothing, it just got stuck after pressing return key. Thought I would give the website a try.

Edit- I checked the SHA256 checksum in another tool and received this-

Same as the other website. If the download size is similar to the last byte, how can the checksums differ?

It is possible, but in order to find out if at least your downloaded image is corrupted, you have to check its sha256 checksum.

They all fetch the images from our rsync server.

The problem with the website is that something could have gone wrong while uploading the file. I’m not a windows user, but maybe this here helps.

Similar checksums from 2 different website, albeit the wrong one if you compare it to the one mentioned on the website.

Try to download the image from a different mirror. I’ll try to reproduce the problem with the mirror tomorrow. Did you download via browser or FTP client?

I got this from my browser. Trying for a different mirror.

Could also be your HD is going out.

I got it from a different mirror, checksum is correct now.

Edit - extracted properly, image checksums match too. But Rufus fails at 99% while writing to USB.
“Bad request”
Nevertheless, I tried to boot with it. And this is what kept coming over and over again.

Edit 2- Rufus write was complete this time, still getting the same error in the above screenshot though.

Press 3 at the boot menu to enter the loader prompt. Then type:

set hw.sdhci.enable_msi=0

Trying this.
Btw, this will not affect anything regarding my windows installation or it’s drivers right?

It has nothing to do with your Windows installation. This setting is only temporary. If it works you can make it permanent by adding the line hw.sdhci.enable_msi=0 to /boot/loader.conf.

Sorry, that didn’t help either. Getting the same output as above. Tried it twice.
Always getting dumps after the Realtek Bluetooth Radio at usbus0 like in the screenshot above

Enter the loader prompt again, and enter:

set hint.sdhci_pci.0.disabled=1

Thank you, that helped me boot into the system and install the OS. I can’t get sound though. Zero sound. None of the apps have any output, both on laptop speaker and earphones.

Edit - Can’t connect to wifi either. When I try to open network manager, I get this error.

Also, I can’t ride the PCI parameter to loader.conf. It says the file is read-only.

Have you set the correct default audio device if there is more than one? What does cat /dev/sndstat output?

Ah, the good old wifi problem. If it’s not working out-of-the-box your wifi NIC is probably not supported. But out of curiosity, what does pciconf -lv | grep -B3 network show?

I suppose you tried to open that file as user nomad. You have to be root to edit system files. The loader variable you set, must be added to /boot/device.hints. You can open that file as root with the ee editor as follows:

sudo ee /boot/device.hints

cat /dev/sndstat
It should be the first one I think. i have only my laptop speakers. I tried all three of them, didn’t get any output.
( Screenshot below)
Regarding the Wifi issue,

I guess nomadbsd isn’t for me :frowning:

Edit 2 -
I have reached my replies limit for my first day of signing up , came up here just wanted to express some gratitude.
Thanks for all the help.
Hopefully someday I can nudge someone towards NomadBSD when they require so. :slight_smile: