How to update an existing USB image


I am a FreeBSD user and decided to try NomadBSD as it seemed quite sleek and I can always do with a “portable” device that I can use wherever I go. My USB stick is encrypted (both the boot and the data partition) to keep my data safe.

I am on an older release, and thereby trying to figure out how I can “update” or “upgrade” the existing system. I tried freebsd-update and nomadbsd-update update with zero success. I tried the website along with several popular search engines with no indication as to how this should be done.

On top of that, I was not able to update any of the packages – which is a concern as I would have assumed that I can upgrade the packages to the newer version in cases of security updates. But that seems quite unlikely at this point as well.

Would appreciate if someone could please point me to the right direction.

Best regards.


What do you mean when you say you tried freebsd-update with zero success? Do you have an error?

NomadBSD doesn’t include an updater tool, but you can always upgrade the FreeBSD base system with sudo freebsd-update fetch install.

What is your release?


Thank you for your response.

My current system is

FreeBSD NomadBSD 12.1-RELEASE-p1 FreeBSD 12.1-RELEASE-p1 r355402 NOMADBSD amd64

As for the error, here it is
sudo freebsd-update fetch
freebsd-update: Directory does not exist or is not writable: /home/freebsd-update
nomad@NomadBSD ~> ls /home/
compat nomad pkgs

It is slightly confusing as to why should this require a freebsd-update directory in /home, and if it does, why is it not there already.

Anyway, once I manually created it, it appears to be going forward. Now to tackle the packages.

Thank you for your help. Much appreciated.


NomadBSD and FreeBSD are both totally new to me, so there probably is a better way. Here is how I updated the packages on my USB flash drive installation of NomadBSD:

 sudo pkg update && sudo pkg upgrade 

@BOFH I suggest to use

sudo pkg update && sudo pkg upgrade
like @Russ advised.
I just use the OctoPkg app for any updates.

If you try to use
sudo freebsd-update fetch install
you perhaps can get into problems. It is possible that you download a new version of FreeBSD (i.e. 12.1-RELEASE-p3)which normally is a good way. But I don’t know if this works in NomadBSD

I even prefer the terminal commands, but I try to avoid damaging my fresh running Nomad. :grinning:

Thanks to everyone for their suggestions. As stated earlier, after creating the non-existent directory, the commands worked as expected.

@mameko, I used the comand line
sudo freebsd-update fetch install
and so far have not noticed anything unusual (apart from the growing number of open files even on an idle system – but cannot tell if it was there even before my update). So far things appear to be pretty stable.

Thanks everyone once again.
Best regards.

Sounds like you ran into the same issue I had back in October. I opened an issue and it was closed as fixed. My issue was for an install to disk, but might apply to your case too.

If you are concerned use:

sudo nomadbsd-update fetch install

I’ve never had any luck with nomadbsd-update upgrade. From what I can tell it attempts to pull down an index file from a location that doesn’t exist anymore, so I’ve just stuck with freebsd-update fetch install.

I use:

sudo nomadbsd-update fetch install


sudo pkg update && sudo pkg upgrade

They each seem to do their own thing. If I’m not mistaken, one for the operating system and the other for the packages.

There seem to be two issues with upgrades to Nomad on USB: (note: my usb is 8 gb):

  1. Using the terminal commands, I had no problem updating the free bsd side, ending with FreeBSD 12.1 Release p3. After doing this I have encountered the problem whereby prior to the upgrade the USB worked on all 4 of my computers, however afterwards, it either would not boot on newer hardware (3 systems) or it lost functionality. I.e., no wifi, pointer and track pad issues, etc.
    It is now runs 100% only on 14 year old Old Reliable.

  2. Assuming that the above might be related to not yet updating/upgrading packages, I updated successfully, but, when upgrading packages encountered “pkg: not enough space in /tmp/pkg, needed 582 MiB available 435 MiB” I know why this is happening with this particular USB.

Re No. 1, I am not sure why all the problems on newer hardware, after working fine on all systems prior to the upgrade to 12.1 p3, other than that, of itself, is causing issues with all but the oldest system.

Re no. 2, The resolution appears to be installing to hard drive on Old Reliable to overcome the out of space issue.

In both instances, it may be because, if you wish to run from persistent USB only, you leave it “vanilla”, as originally downloaded and initially set up.

This is the reason, why I suggested to only use

# pkg update && pkg upgrade

The developers published this version of NomadBSD with FreeBSD 12.1-RELEASE-p2 as the base system. With
# freebsd-update fetch install
I could get into problems with installing 12.1-Release-p3. NomadBSD is a special build of FreeBSD and should be used with the original base system, I think.


@austinwi, I suspect both of your issues might be related to the lack of space – the update left important files required to boot into the newer systems due to lack of space. Furhter investigation requires understanding if the newer versions were using UEFI or bios boot, at what point are they failing, etc.

In my experience, I have had no issue with freebsd-update fetch install and subsequent pkg update && pkg upgrade. Yes, it took a long time to complete, but it did go through and the usb still works. It may be worth running the same steps you did using the same hardware on a relatively larger USB and see if the issue can be reproduced.

Best regards

1 Like

Thanks BOFH. I expected that was the problem, as the USB thumb drive in question worked great until I performed the operations and is “maxed”. Once the quarantine is over, I will get a new, larger, faster USB3 drive and go from there.

Thanks again for your input, And to mameko, as well. Most appreciated.