Having difficulty running NomadBSD on ECS A68M-C4DL mobo desktop

Hello everyone. Good day to you. I had been using with limited experience on BSD since I installed and dabbled on the then newly released PC-BSD 9 had fun on it for about a year but then the old desktop conked out so that was my last foray with BSD. But I have been to a lot of Linux distros since then. Last week while looking for something on the internet a youtube NomadBSD review caught my attention. So then a few days ago I finally downloaded the image NomadBSD. And I made a live USB and installed it. It went perfectly until I was rebooting the OS and got to the point of choosing the graphics accelerator. That is where the problem: every time I enter OK it made some processes then it goes blank…nothing. I keep repeating the installation process with different choices on the graphics accelarator but the same result: it just went blank.
I left it for about 30 minutes hoping it was just running in the background but no. So I finally gave up.
Any tips you have I will be grateful.

Hi there @tybuzz67,

welcome to the forum!

Have you tried to select the VESA or SCFB driver? What does the command pciconf -lv | grep -B3 display say?

yes I did still i got blank. I think it is not the display per se that is the problem but that the OS just hanged or crash…coz I have not gone inside the OS yet, after selecting VESA or to autodetect it did some process then blank even the harddrive LED light is not blinking just dead for 30 minutes so I turn the machine off.

maybe this version of NomadBSD doesn’t have the driver for my mobo?