[Growfs] : requested size is not larger than the current

Hi everybody

Running growfs to expand an ufs fs from 3.9G to the partition size (29G), growfs complains what you can see on the following sreenshot.

my nomadBSD runs on virtualbox and the related virtual disk is a dynamic vdi one. It’s an image of an SSD card.

smart suggestions are welcome.

thanks a lot by advance.
Have a nice day.
Cheers

Hi @didier,

I’m confused about the layout. NomadBSD’s layout looks like this:

=>      63  61685697  da0  MBR  (29G)
        63         1       - free -  (512B)
        64     81920    1  efi  (40M)
     81984   8275968    2  freebsd  [active]  (3.9G)
   8357952  53327808    3  freebsd  (25G)

What happened to ada1s3 (/home)?

Hi Mark,

History: root filesystem ([active]) has been rapidly full (At nomadBSD’s install, I had chosen automatic partitioning) by installing ports.

Why: So, I decided to fusion / and /home in a same partition because /home was weakly occupied.

Implementation: I’ve backed-up /home mounted fs to be free to delete its partition and restore space for the active partition.
I’ve expanded the root partition close to the end of the media.
Final step, to grow root filesystem. This is where I am. This is my trouble.

Note 1: All these steps have been performed under another bsd system. This explains why root filesystem to expand (/dev/ada1s2a) is showed mounted at /root/rootdisk on screenshot.
Note 2: I’ve tried growfs with /dev/ada1s2a unmounted as well.

Sorry, if I made you misunderstood.
Thank you for your patience.

I see. Boot the NomadBSD you intend to resize into single-user mode, and run service growfs onestart.

Ah ! OK ! To work, the partition must be online/active. That’s I understand.

Yes ! It worked.

That’s why you were surprised /home has disapeared. But it works in single mode.

Thank you a lot.
Have a nice day.
Didier.

1 Like