Errors with linux browser install after full upgrade

Hi Folks,

I have a quick question if somebody also ran into this problem:

I’ve done a full upgrade of all the packages with pkg and a system upgrade with freebds-upgrade.
Which all went pretty well concidering the amount of adjustments that have been made for NomadBSD.
When I try to start the linux browser install/update gui it prompts for my password after entering
it bails out with su exit error 3. I have run several tests and found out that before the upgrade everything
seems to be fine, so something in the upgrade went wrong? Or are there extra packages needed that
I am not aware of?
Unfortunately there is no info I could find on this topic online. And I do like to continue using NomadBSD
sinds I grew pretty fund of it… :slight_smile:

Thx for your help.

I haven’t encountered the problem you described, but I have found that uninstalling and reinstalling the application has helped me on more than one occasion, particularly after an upgrade.

How to uninstall (reinstall) Linux layer? Octopkg does not manage it, and Linux Browser Installation GUI does not provide uninstallation, too — [Deinstall] button is blank there (grayed out).

Disclaimer: This is a half-assed answer! I’m not using this feature.

The menu-item “Network > Linux Browser Installer GUI” is a GUI-python-script

/usr/local/bin/lbi-gui

(there are some uninstall options in the script…!?)

The python-script is utilizing this (shell)script:
mrclksr / linux-browser-installer
Here you might find some answers to your problems / a FAQ…

It looks like it creates a jail where the browser(s) are installed using the linux compat. layer

Have a nice weekend :slight_smile:

First of the following is my opinion. I do not want to hurt anyones feelings :slight_smile:
It is a sad conclusion but it is the same thing as with the other bsd fork (I forgot it’s name) they later switched to linux because of this.
BSD just doesn’t work this way, sure you can make a nice looking desktop and maybe the developers can stear things but from end user point of view keeping it updated is a nightmare!
It’s not completely compartible with main bsd so it will always screw up. Just like the other one I mentioned earlier! If you run a desktop like this there are just to many compromizes.
Therefor I think nomadbsd should be ran as is and upgraden with a new release from the developers only!
I myself went back to original freebsd and I am currently in the process of building a box from scratch. This does’n mean I will be gone, I will keep an eye on nomadbsd :slight_smile:

Well, it could also be used as a motivation to roll up your sleeves and start learning to solve your problems via the commandline :wink: and scratch your own itch.
…just like you do, @Patser :+1: -but you can do it here on NomadBSD. Just start by making a backup/snapshot of your system.

Happy problem solving to all

You find the necessary information here:

It principally boils down to actually set the value inside /etc/rc.conf for linux_enable from true to false, stopping and then restarting the linux service. For more sophisticated troubleshooting, please, refer to the handbook.

1 Like