DSBAutostart don't work

Hello everyone,
after the installation of py38-xdg as suggested in another post, i tried to configure DSBAutostart like this
DSBAutostart
but at reboot it don’t work.
Even with a complete path to the applications it don’t work.

Any suggestions?

Thanks

Hi,

what happens when you run /usr/local/libexec/openbox-xdg-autostart in a terminal? Are there any error messages?

This the output. “Mamma mia!” say an italian when there is confusion like this.

/usr/local/libexec/openbox-xdg-autostart
Could not connect to wayland display, exiting.
Impossibile avviare il metodo di regolazione wayland.
Tentativo con il metodo successivo…
[ 24.07.2021 10:17:19.151 session_init FATAL ERROR ] Another composite manager is already running
Metodo in uso “randr”.
Waiting for initial location to become available…
Posizione: 41.50 N, 12.30 E
tint2: Using glib slice allocator (default). Run tint2 with environment variable G_SLICE=always-malloc in case of strange behavior or crashes
tint2: xRandr: Found crtc’s: 4
tint2: xRandr: Linking output VGA-0 with crtc 0, resolution 1920x1080, DPI 101
tint2: xRandr: crtc 1 seems disabled
tint2: xRandr: crtc 2 seems disabled
tint2: xRandr: crtc 3 seems disabled
tint2: No XSETTINGS manager, tint2 uses config option ‘launcher_icon_theme’.
tint2: Loading config file: /home/borgio/.config/tint2/tint2rc
tint2: real transparency on… depth: 32
tint2: panel items: LTSC
tint2: Systray composited rendering on
tint2: nb monitors 1, nb monitors used 1, nb desktops 1
tint2: panel 1 uses scale 1
tint2: Loading icon theme cache…
WARNING: Unknown keyboard shortcut: ‘ctrl+grave’
(uint32 1,)
CRITICAL: Cannot acquire ‘org.freedesktop.Notifications’: Name is acquired by ‘dunst’ with PID ‘1581’.

The system is running from an external SSD.

The output looks OK, so far. Could you please post the content of the desktop file for firefox under ~/.config/autostart/?

borgio@NomadBSD ~/.c/autostart> ~/.config/autostart/
borgio@NomadBSD ~/.c/autostart>

Find the desktop file for your firefox autostart entry:

% grep -i firefox ~/.config/autostart/*.desktop`

Then post its content here.

borgio@NomadBSD ~> % grep -i firefox ~/.config/autostart/*.desktop
fish: Unknown command: ‘%’

borgio@NomadBSD ~ [127]> grep -i firefox ~/.config/autostart/*.desktop
borgio@NomadBSD ~ [1]>

What version of NomadBSD are you running? According to your screenshot and the absence of any .desktop files under ~/.config/autostart, I seems you’re using an old version of DSBAutostart, which uses ~/.config/DSB/autostart.sh.

As you can see, i installe NomadBSD 130.

Can i create the autostart directory?

Actually i have the autostart dyrectory, but the file autostart.sh is under ~/.config/DSB/ directory. Can i move that file under ~/.config/autostart/ directory?

Proceed as follows:

% sudo pkg delete dsbautostart
% git clone https://github.com/mrclksr/DSBAutostart.git
% cd DSBAutostart && qmake && make
% sudo make install

Then create the autostart desktop files from your autostart.sh:

% dsbautostart -c < ~/.config/DSB/autostart.sh

Thanks a lot.
All went well.
The system is PERFECT!!! :sparkling_heart:

1 Like