Drops to mountroot

Folks, I am pretty experienced with Linux and grub commands but am struggling here.

After seeing your OS demonstrated on Explaining Computers YouTube channel thought I’d give it a try.

Gives error as follows; mounting from ufs:/dev/label/nomadroot failed with error 2 then dumps me to a command line with a mountroot > prompt.

I’ve written numerous linux live images before with no problem so am baffled by this, followed your instructions using dd (which is what I always use) and tried 1.3.1 and 1.3 just in case but both the same.

I’ve tried to use grub on my main system with a simple chainload but still no luck.

Any tips greatly appreciated.

Geoff

Hi there Geoff,

it might be a timing issue. Boot NomadBSD and press 3 at the boot menu to enter the loader prompt. From there type:

set vfs.mountroot.timeout=30
boot

If that solves the problem, you can add the line vfs.mountroot.timeout=30 to /boot/loader.conf.

Thank you for quick reply, unfortunately back at the same mountroot 》 prompt :grimacing:

Geoff

Try the same procedure, but this time with

set kern.cam.scsi_delay=100000
boot

at the loader prompt.

Strangely after entering that variable it goes to mountroot prompt very quickly.

Thought I may have entered wrongly so repeated and issued ‘show’ before booting to check variable.

So again no good. I am baffled by this, done this procedure so many times with Linux and Raspberry Pi images, cannot fathom it.

Geoff

Try a different USB port. If possible use a different USB flash drive.

1 Like

Funny you should say that, I have en external USB3 HD drive with four different Linux OSs on various partitions, works perfectly. Naturally I wanted to run nomadBSD from USB3 so used the same port.

Changed port and it works fine.

Oddly not sure it is a USB3 issue as I have a USB2 and a USB3 socket beside each other on one side of my Toshiba laptop and it doesn’t work in either of those but USB2 socket on other side of computer fine.

Thank you for your ideas today, although they did not resolve the issue sometimes one idea leads to another.

Geoff