Desktop not starting after installation on HDD/SSD

So here’s my problem.:

I installed NomadBSD on a USB stick to test it, it worked fine and when it booted, it started the desktop automatically. After that, I started the installation of NomadBSD on my SSD. The installation was doing it’s things and finished after some time. After the installation on m SSD, NomadBSD was still running on my USB stick. I’ve shut down my computer so I could boot NomadBSD on my SSD. I removed the USB stick from my PC and THEN I powered on my PC. After starting my computer, it started to load the booting files in the SSD as it’s supposed to and now I have the NomadBSD boot menu in front of me with options with the countdown before booting the OS. I pressed “Enter” and everything started to load. After waiting for everything to load, I have the “Login” screen of FreeBSD with a black background. So what do I do now? Is it supposed to load the desktop environment automatically just like it did when booting from the USB stick or am I supposed to do something at this point? Was I supposed to boot it from the SSD while keeping the USB stick plugged in? Is it because I’m trying to boot it on a computer with 2 CPUs? Is it because I have too much RAM memory(192Gb)? Is it because my SSD is plugged directly to the motherboard on a SATA port? 'Cuz right now I’m kind of lost on what’s supposed to happen or what I’m supposed to do… Can anyone help me figure this out?

Hi @Thomas_Boucher,

when you install NomadBSD to a HDD/SSD, the install program installs the graphics driver which in use by the system you are running, and then the automatic graphics detection is disabled. There might have been a problem with the installation of the driver. You can enable the auto-detection by logging in as root, and run the command sysrc initgfx_enable=YES. Then reboot with shutdown -r now.

Could you tell me what’s the output of egrep 'initgfx_kmods|kld_list' /etc/rc.conf?

How can I do this | character with the keyboard?

kld_list=“cuse4bsd /boot/modules/nvidia-modeset.ko /boot/modules/nvidia.ko”
initgfx_kmods="/usr/local/nvidia/440/boot/modules/nvidia.ko /usr/local/nvidia/440/boot/modules/nvidia-modeset.ko"

that’s what it’s showing me

That looks OK. Does the GUI start if you enable the auto-detection as described above?

nope it doesn’t

Log in as root, then:

rm -f /var/

still not booting the GUI… Btw, I noticed that while it was loading, it said 3 times kldloader could not load the nvidia.ko and nvidia-modeset.ko files because there was no such directory

Ah, now I see where the problem is. The latest Nvidia driver changed from 440 to 460.

Log in as root, then:

sysrc initgfx_enable=NO
pkg install -y nvidia-driver

Change or create the file /usr/local/etc/X11/xorg.conf.d/00-video-initgfx.conf as follows with your favorite editor:

Section "Device"
    Identifier    "NVIDIA CARD"
    VendorName    "NVIDIA Corporation"
    Driver        "nvidia"


How do I create a file? sorry if that seems dumb but I’ve never used bsd before

Just open (or try) to open the file with the easy editor (ee) as follows as root:

ee /usr/local/etc/X11/xorg.conf.d/00-video-initgfx.conf

Save when finished editing.

When I want to save the file, it says “unable to create file “/usr/local/etc/x11/xorg.conf.d/00-video-initgfx.conf””

Have opened as root?


that’s ALT + C to save right?

Make sure the x in X11 is upper case.

the only difference between what you want me to write in that file and what is already in the file is the line [BusID “PCI:15:0:0”]
which is present in the file that is already there

Press ESC to enter the main menu, then press c for the file operations, then c again for saving.
If you changed the file, and you try to leave, ee will ask you if you want to save.

OK. Then leave it like that. I thought the initgfx script deleted the content or the file.

it works now. Thank you very much for your time :grin: