Can't upgrade to 1.16.1

start the upgrade with OctoPkg; after fetched all packages and began to install-extract them, here are the first red messages:

[20/281] Upgrading libgpg-error from 1.39 to 1.41…
[20/281] Extracting libgpg-error-1.41: .
[25/281] Deinstalling libsoup-gnome-2.62.3… [25/281] Deleting files for libsoup-gnome-2.62.3:
[32/281] Deinstalling librsvg2-2.40.21…
[32/281] Deleting files for librsvg2-2.40.21: … done

at the point of
[36/281] Installing librsvg2-rust-2.50.2…
a warning windows tells:
su returned with exit code 3
click on OK

and try to start the upgrade again then

"Starting package upgrade… Shared object “” not found, required by “”

Command finished with errors!"

and the system becomes unusable, non more applications can be opened.
How to get out from there?
Thank you

Could you please explain what you want to upgrade to 1.16.1?

What does freebsd-version -uk return?

you can see:

with sakura
pkg delete -f librsvg2
pkg lock -y consolekit2-1.2.1_1
pkg lock -y e2fsprogs
pkg upgrade

Hi, forgot to tell that system is a full installation on a volume, not live usb.
Just accepted the package upgrade proposed in OktoPkg
"There is one outdated package in your system:
Outdated version
Available version
1.16.1 "

mauro@NomadBSD ~> freebsd-version -uk

Hi, forgot to tell that system is a full installation on a volume, not live usb.
I made the upgrade by sakura using the command you’ve indicated, the upgrade goes well to the end, but then the system behaves weirdy (applet tray icons disappear, shutdown gadget not working when clicked). the upgrade is from 1.15.10 package to 1.16.1 as written before

I have the live persistent usb and I get the same. Upgrade or an install breaks NomadBSD for me.

Upgrade or an install breaks NomadBSD for me too.

I reinstall it.

Before upgrade I do

cp /usr/local/etc/dsbmd.conf /home/nomad
pkg lock -y e2fsprogs
pkg lock -y consolekit2-1.2.1_1
pkg delete -f librsvg2
pkg update
pkg upgrade -y

cp /home/nomad/dsbmd.conf /usr/local/etc/


Actually NomadBSD run and I can do another upgrade

Maybe we have another solution…

ok, now made this as well, in my case /home/nomad/ becomes /home/myuserdir and consider that every time I restart from the previous clean condition by a backup cloned volume.
No improve, upgrading goes to the end successfully but at system restart I have only a partially working system as for last attempts.
No more applets icon on upper system try bar, some dock program icons do not respond, maybe going ahead with other tests I’ll find other oddities. Hope this issue will be solved in a next release. Futhermore, just highlight if it can mean something in the case, that my system icons theme set is not the default one (Papirus), I had changed into Faenza Ambiance just after the first installation, however this did not affect the system in the previous package upgrade.
Thank you

Sorry I can’t help you, perhaps another more experienced person could provide a solution.

I appreciate all suggestion provided, I learned something more.
thank you

Hi, I’d like to put [SOLVED] in the discussion header, don’t know why I’m not allowed to modify anything even though I’m logged in the forum and I’m the one who started the discussion.
However, I’ve remembered to go back and read the errata suggestions to avoid the system messing up after the package upgrade, same as I did in the last upgrade.
I was just missing the

pkg delete -y qt5-style-plugins

pkg install -y qt5-style-plugins

commands to give at the end of the upgrade and before poweroff.
After that, everything is back working at reboot.
Thank you once again