Cannot start X server during install

I’m a noob and I’m trying to install NomadBSD. I get all kinds of error messages about X server not being started, like “No devices detected”, “Fatal server error: no screens found(EE)”, “unable to connect to X server: Connection refused”
I made a few screenshots, but because I’m a new user here I’m only allowed to upload 1 file, so I combined everything:

How can I make sure that there’s a GUI and I can properly use NomadBSD like how it was supposed to be?

Hi there @bran.damon,

welcome to the forum.

Enter your BIOS/EFI setup, and disable one of the graphics chips. If that’s not possible, you can try the following:

Reboot, and then enter the loader prompt by pressing 3 at the boot menu. Type:

set hw.pci.default_vgapci_unit=0
boot

Setting hw.pci.default_vgapci_unit to 0 will make your Nvidia the default device. You can also try to set it to 1 to use your Intel IGPU. If it works, make it permanent by adding the line hw.pci.default_vgapci_unit=X to /boot/loader.conf, where X is either 0 or 1.

@mk1 thank you for the quick answer. Setting the hw.pci.default_vgapci_unit option either to 0 or 1 produced a whole slew of errors, but after unticking the Switchable Graphics in the BIOS, everything worked fine, so the issue is solved. Thanks again!

1 Like