Can not login after update with OctoPKG

Hi there,

this is my first post here and the first time i (try to) use a bsd distro.
I use Debian and Arch Linux on a daily basis, meaning that i know how to use a console.

I installed “nomadbsd-1.3.2.img” as a guest in VirtualBox with Archlinux as host.
All went fine until i used “OctoPKG” to update the database.
Syncing and fetching the database updates went fine, then a message (at the bottom) said 1 tool is upgradable. I clicked install and after that a complete systemupdate automatically started and ended with an ERROR at a “GTK3” package. Since then, when i reboot, i can not login with the DM slim.

The system boots up normal, but the autologin feature of slim does not work.
Instead, the login screen with the user “nomad” predefined (namefield can not be changed) is shown, when i enter the password of that user, it throws me back to that login screen with no username predefined. No matter which username (nomad or root) i then try, it brings back the login screen.

So, for now i can not login to the system, any ideas how to solve this issue?

Using the 2nd bootoption (singleuser) gives me a console where i can login
as root with “su -”, may be this is a starting point to correct the update error?

greetings from Germany

the same error appeared in a new VM.

This time i didnt use OctoPKG but “sudo freebsd-update fetch”
and “sudo freebsd-update install”.
Took a “little” time for the downloads… but it worked.

Then i used “sudo pkg update” and after that “sudo pkg upgrade”.
Here comes the problem, the “disk” is full and not writeable anymore.
I have tried to copy and save the errormessages into a textfile for later use
and that was not possible due to the full disk.

I looked at the nomadbsd files in the host system (Arch Linux), there are 2 files:

  1. nomadbsd.vmdk (as adviced by the handbook)
  2. nomadbsd-1.3.2.img

None of these files changed in size after updating & upgrading the system:

  1. nomadbsd.vmdk (651 bytes)
  2. nomadbsd-1.3.2.img (5 GB)

This is probably part of the problem…

I have installed FuryBSD in a VM, this resulted in a *.vdi file which increases in size when updating and upgrading the system and everything works fine.

Hi @h.wurst,

did you truncate the image to a reasonable size before creating the .vmdk file?

If you want a regular installation:

  1. Create the .vmdk file from the NomadBSD image
  2. Create a new VM with that image, and add a virtual HDD (>= 16GB) to install NomadBSD on.
  3. Boot the .vmdk image, finish the setup, reboot.
  4. Run the NomadBSD installer
  5. Boot from the virtual HDD

the size of the “nomadbsd.vmdk” in VirtualBox is set to 16gb,
this is the default setting by VirtualBox.

How did you create the .vmdk file? If you followed the instructions from our handbook, the option -rawdisk implies that the available space is determined by the image file.

the size of 16gb is set by default by VB no matter what size the raw file is and i didnt changed that, because i thought 16gb would be enough space for the persistent *.img.

Probably that was my mistake, i thought it is enough to make a *.vmdk file from the NomadBSD image and use that persistent system as a regular installed system.

I have followed your hints and created a 16gb vdi, rebooted and started the installation, which is running right now. I hope that the HD “ada1” the NBSD Installer found was the right one.

I’ll check back later when the installation has finished, thank you so far.

Here is a screenshot of the VB settings:

and the installation:

According to your screenshot the .vmdk file is 4.66GB. This is the size you get when you don’t truncate the nomadbsd-1.3.2.img file before creating the .vmdk file from it.

ah now i understand what you mean,
you say i should have reduced the *.img file in size before creating the .vmdk file from it,
to give the persistent system more space for updates & upgrades, right? I thought VB would give that file 16gb, my mistake…

Success, the installation went through, the *.vdi file is 4.2gb.

Thank you for your help!

I have another question:
How can i “compact” the nomadbsd.vdi file in bsd, after updates and upgrades?
I know how to do that in Arch Linux, but this is for a ext4 filesystem and
i dont think it will work with a ZFS filesystem too.

On Linux its within the guest, just a “bleachbit -c system.free_disk_space”,
is there something comparable in BSD i can use?

Should i open another thread for that question?

Yes, but you have to increase the size of the image using the truncate command. From the handbook:

NomadBSD will use the remaining space on a USB flash drive for its /home partition, but since we intend to run it from an image file, we increase the (potential) size of the image as follows: truncate -s +4G nomadbsd-x.y.z.img . If you need more or less extra space, change the -s parameter accordingly.

I’ve never used anything like bleachbit, but I think you can script something like that yourself.

Thank you, i didnt understand that before, i will try that later.
For now, i’m happy to use the regular installed system.

Have you tried to run bleachbit from source? says you only need to run (g)make and python3.

I used dd for that, but it took a lot of time…
dd if=/dev/zero of=/fillfile bs=4M