Brightness and Gamma not persistent

I love the software brightness and gamma adjustment settings, however I can’t make those slider adjustments persist after a few seconds, even when saving the setting.

When I move the sliders, I can change brightness and gamma - temporarily - and in a few seconds, the screen goes back to normal. The sliders do not move back to the default positions I found them in, but stay where I moved them.

Seems like something in my system initially allows for the adjustments, but it quickly gets disregarded back to normal.

Not a showstopper issue - I’m lovin’ NomadBSD more and more each day, but maybe there’s something I’m missing?

1 Like

Hi @Rando,

redshift is running by default, and it constantly adjusts gamma according to your surroundings. You can disable it by removing the autostart entry under Openbox menu -> Settings -> Autostart settings.

1 Like

Thanks mk1 ! That cured it - seems redshift was fighting my manual settings.

I actually like redshift, so I made note of the command to make it active again adding/editing in the command later.

Now I understand the controls better - only gamma adjustments are persistent, and proven upon either logout/login, or reboot, but not brightness, which seems session only.

Which makes sense - if brightness were persistent, then one runs the risk of accidentally turning brightness all the way down, and upon reboot, having no way to see the controls to fix it! :slight_smile: Cool.

Thanks again - I’m really liking the custom tools in NomadBSD like all the DSB* utilities and whatnot which sets this apart from the usual DE’s. Nice work.

1 Like

redshift is running by default, and it constantly adjusts gamma according to your surroundings. You can disable it by removing the autostart entry under Openbox menu -> Settings -> Autostart settings.

It also works with me, disable redshift! thanks for that !!!
Now the gamma correction and the brightness software work perfectly, although the F6 (brightness down) and F7 (brightness up) keys don’t work on the laptop, maybe I’m missing something…
I’ll also try it on the desktop PC to see how it works.