Boot hangs on hp laptop

hi all
I’m booting from USB using a fresh downloaded nomadbsd-1.4 on my hp elitebook 840 G7.
USB is verified and works on other hardware.

Reading in this forum I found I can switch AHCI to IDE but I can’t find this option in my BIOS.

Is there any workaround?

Thanks in advance

have to say that I’ve almost same issue on my hp laptop, while the 1.3.2 version has previously been installed and working .
In my case I can run the first time setup and arrive at the end of the installation, but then after reboot when modules are loading I’ve some warning and the boot sequence begins looping without getting the desktop to start.
I’m afraid cannot give any detail of the warnings as don’t know how capture them on the display

update: I’ve just been able to install/configure the 1.4 release which I was fighting with, hardly attempting to deploy it from some USB pendrives finally revealed unrelyable, and succeeded only after having discarded two pendrives.
It might be a way for solving your issue, try a different 3.1 USB of a known manufacturer (ie. Sandisk, Samsung) even if it costs a bit more.

my pendrive is Sandisk but I’ll follow your advise trying other pendrives

changed pendrive and downloaded image 1.3
same KO

which iso/img burning application do you use? If from inside Windows, try with Rufus if not already done, or else with Balena Etcher (both also portable)

I use linux, artix to give a distribution name, so I used dd as reported in following link

I tried FreeBsd too, but without luck.
Maybe it’s a issue related to the recent Intel i7-10510U processor.

Before you start throwing USB sticks away, here is how I got NomadBSD on an old thumb drive.

Plug the stick into your Linux distro and use something like GParted (or “Disks” in *buntu’s) to find/identify your stick. MOST LIKELY the first window will be your PC hard drive => NOT What you want to play with!! Look in the upper right for a select window to find the USB stick (mine says /dev/sdb1) and select you stick. Hint: the stick display has the gig capacity of your USB stick.

You will delete the “partition” from the stick after you have basically off-loaded ANYthing of value because all data will vanish upon deletion. Now make one, new partition that uses the entire stick BUT leave empty some space “in front” and space “behind” the designated partition (20-30 k each). Format the disk to “FAT32” and the disk is ready. Maybe I am superstitious but I never trust a partition that does not have a little wiggle room.

Drove myself crazy using dd with the of=/dev/sdb1 in the command line. Turns out I had to dd to the “node” (I think that is what it’s ID was). That means I has success doing the dd command and sending the .img to “of=/dev/sdb” (no number!). It is not the same as GParted identified the partition (/dev/sdb1). Normally I play with .iso files burned into DVD’s , so the node thing was new to me (not unlike NomadBSD).

Main thing is it worked for me and gives you a couple of attack points to try!!