Boot fails on Lenovo E14 G3

I tried ro start NomadBSD with different USB sticks but my Lenovo Thinkpad E14 G3 (with AMD Ryzen 5) denies to boot. UEFI secure boot is switched off. After entering the boot menu the USB stick is available for selection in the list of boot devices. Confirming the entry has no effect - I’m always rejected to the boot menu without any visible action.

So I put the same USB stick in an old Samungs R530 (Core2duo) . No problems. The Samsung booted NomadBSD, the configuration process worked well and ended with success.

So I tried to boot the Lenovo with a MX Linux image (Debian based) and it worked without problems. Conclusion: the Thinkpad E14 rejects only NomadBSD.

This is the failing version: NomadBSD 131R-20221130 (64-bit/x86-64/amd64, UFS)

Any idea? Do I have to change any other BIOS settings beside the Secure Boot-Option?

Welcome to NomadBSD, Ralf.
I used till now several USB sticks and external SSD with NomadBSD on 3 different machines and all worked fine.
Your USB stick seems to be okay. How did you write the NomadBSD image to the stick? With Linux and “LZMA/DD” or Windows and Balena Etcher?
Sometimes I changed from Linux dd to Balena Etcher and vice versa when running into booting problems, and then it worked. Magic probably…
For testing, you can download a small FreeBSD image from Write it to your stick and boot this. NomadBSD is based on FreeBSD, and it should be the same boot process. Look, if this works.

I don’t have a Thinkpad, so I cannot talk about it and NomadBSD. I’m sure, you will get it running and then you will love it. :slight_smile:

Hi Mameko,

I copied the image with dd via Linux on the stick. And it booted and worked well on with an my old Samsung R530 Notebook (13 years old …) producing al lot of heat :slight_smile: but my Thinkpad denied to boot the same stick.

It is a good hint to try a FreeBSD image. I’ll gonna try it. Thank you for your advice.

Thank you for the hint.

The FreeBSD-Image immediately started and worked well from a 2 GByte USB device. So I flashed NomadBSD on an older USB stick of 8 GByte capacity, and … it worked!! NomadBSD started on my Thinkpad E13 G3. Perhaps it formerly failed due to the high capacity of the other stick (64 GByte, 32 GByte … Don’t know)

Only the wireless device unfortunately doesn’t work. It is a Realtek 8822CE Wireless LAN 802.11ac

Sometimes it is weird. I have an external SSD with 128 GB and NomadBSD works fine with it. I installed Nomad on my internal SSD of my laptop and use the external device as a backup.

Wi-Fi is always a little bit difficult on FreeBSD. Some devices work, others not. Especially new ac-device with fast Wi-Fi are sometimes unsupported till now.
My Intel AC 9560 was first supported in FreeBSD 13.1. Before that, I used a Wi-Fi bridge, which I connected to the normal Ethernet port. This was a good and cheep solution. Or you use an older device which is usable.