Boot device (USB stick) "did not authenticate"


I used Rufus 3.11 to create bootable NomadBSD 1.3.1 (using - unpacked by 7-Zip 19.00).

Windows 10 Home sees the USB memory device (SanDisk), but the (HP) UEFI refuses to boot from it.

Has anybody experienced the same issue? What may be the cause?


Hi there @comanchero,

you probably have to disable secure boot, which is not supported yet.

1 Like

Hi, @mk1,

THANKS for your quick response.

How to do that, please? You mention “not supported yet”. However, Linux (e.g., Ubuntu) does not exhibit this behaviour.


Check your UEFI/BIOS if there is such an option.

Some Linux distros seems to support it, but FreeBSD is not Linux :wink:

1 Like


THANKS, I’ll try.

Yeah, I know. :innocent: That’s exactly, why I’m gonna try it out. :+1:


now (after disabling Secure boot) it boots, but the promised Wizard will not open/start.

The textual (terminal) boot sequence ends up with options, such as “Single, Multi-…”, etc., out of which none leads to the expected GUI (of any kind).

So, what to do next? (Initially, I just wanted to run NomadBSD in the live mode.)


Can describe (or take a screenshot with a camera) where the boot process stops?

1 Like

Hi, @mk1,

unfortunately, somehow I cannot get photos from a camera to the PC, but I’ll try to describe:

1st stage is the one with the blue lettered/symboled NomadBSD logo - the one with the 4 + 2 options. (If I don’t stop the countdown by Esc, then it continues to the 2nd stage.) I thought that maybe AMD/ATI Graphics could be the issue. But honestly, I don’t know how to enter/activate them (neither highlighted letters, nor the numbers work - “Unknown command” is the system’s response; I’ll try the Fs, yet).

2nd stage happens when I either do nothing or hit Enter in the 1st stage - then a long sequence that, ends with the “mountroot” - thus I tried USB 2.0 port, but that did not help. Hitting Enter with the mountroot weirdly leads to booting (the pre-installed) Losedows.


Wait for a minute before pressing any key when you reach the mountroot prompt. Check if any messages about da0 appear. If that’s the case there is a timing issue.

Hi, @mk1,

I did, for >5 min., maybe 10, but absolutely NOTHING happened. :frowning_face:


when you see the sexy FreeBSD Ascii logo press space bar you should see a promot something that resembles ?> or something I forget it’s been a while.

type in boot -v and let it move down and paste it here if you can.

Different HW has different bugs and sadly OSS are not as aware of these bugs so quarks aren’t added like they are in other OS to bypass, skip dont do that that way or other things to help it work.

hopefully I did not offend half the internet by saying “sexy” seeing that’s the world we live in now.

1 Like


THANKS, I’ll try.


I’ve got a similar issue with a NomadBSD USB stick on a HP Probook 450 G8 laptop running Windows 10 Professional. I was getting “did not authenticate” message so disabled the secure boot from the bios. Now the boot sequence begins but hangs at “masks” line. The same NomadBSD USB stick boots up to the desktop fine on an old Lenovo Thinkpad X230 running Win10 Pro so it seems to be an HP Probook issue. HELP…

Hi @ChapinTokyo ,

this is a problem with the EFI loader I had as well. Updating the mainboard’s firmware helped to solve the problem. Alternatively, you can boot NomadBSD with CSM (legacy) instead of EFI.

1 Like

Thank you for your advice! I updated the firmware on my HP but no progress. This is a new machine (2021 release) and it doesn’t have CSM (legacy) in the BIOS settings at all. I am now thinking of running NomadBSD in Virtualbox on this machine instead…

You could try the newer EFI loader:

Boot NomadBSD on your Thinkpad X230, and proceed as follows:

# mount_msdosfs /dev/da0s1 /mnt
# cp /boot/loader.efi /mnt/EFI/BOOT/BOOTX64.EFI
# umount /mnt
# shutdown -p now

Then try to boot it on your HP Probook.

Thank you for this suggestion. I tried it today, but even after disabling secure boot, the new HP Probook 450 G8 would not boot to NomadBSD (same “did not authenticate” error message would prevent the boot process from starting).