Black screen after pkg updates

The quarterly pkg update was successfully completed yesterday, but after turning the computer off and then on again today, I am greeted by a black screen, with no GUI.

I still have not found a solution. Corrected 340 to 400 the boot path to nvidia.ko, appended kld_list, switched initgfx_enable="NO" (was YES) in /etc/rc.conf — the same black screen (non-responsive graphical interface appears after Ctrl+Alt+F1, F2, F3 and F9). Log messages say:

Found NVIDIA GeForce GT 240M at 01@00:00:0
sysctl: unknown oid 'dev.hdac.2.polling' at line 56
sysctl: unknown oid 'dev.hdac.3.polling' at line 57
sysctl: unknown oid 'dev.hdac.4.polling' at line 58
sysctl: unknown oid 'dev.hdac.5.polling' at line 59
Configurng vt:blanktimeallscreens.
Starting slim

Maybe Slim is no longer supported? I am still using NomadBSD 13.0 on FreeBSD-13.1p3.


I don’t have quite the same problem but while waiting a minute I got a display.
I am experiencing slowness with the graphics card UHD Graphics 630

Have you been waiting a while? and nothing?

Yes, later on it sometimes appears, although non-responsive, as I said. The mouse cursor only moves, but the context menu does not pop up. The OpenBox menu does not work at all, even Logout.

I have already restored NomadBSD to its previous state (zfs rollback), but the pkg update has so far been unsuccessful.

I am trying to update packages selectively, step by step. OctoPkg, 7zip,, nano, rclone, sakura, zim upgraded successfully, but security apps Kleopatra, ca_root_nss, nss, gnupg, gnutls and automatically involved LibreOffice do not even start after upgrade, so I reverted NomadBSD back to its morning state.

I am noticed interesting report in a shell (fish):

API mismatch: the client has the version 510.60.02,
but kernel module has the version 340.108.
Please make sure that kernel module and all NVIDIA
drive components have the same version.

Not all drivers have their packages updated? Unlikely, because I installed all the updates I received first. Maybe I should update the latest patches of NomadBSD first. Or even upgrade to NomadBSD 131R-20221130 (from 130R-20210508). I will investigate further, thank you for the help.

Turns out you’re right, @bsd276 – GUI works indeed, but very very slowly, practically unresponsively.

I have tried to correct a video driver name from nv to nvidia in /usr/local/etc/X11/xorg.conf.d/00-video-initgfx.conf – even worse, GUI does not start at all after reboot. Perhaps a video driver is not the cause.

A bit weird: NomadBSD 130R-20210508 and all renewed apps work smoothly after the latest quarterly FreeBSD 13.1-RELEASEp3 package updates (379) — until reboot. :face_with_open_eyes_and_hand_over_mouth:

Maybe Slim is no longer supported? I am still using NomadBSD 13.0 on FreeBSD-13.1p3.
I suspect you have seen this : “* The display manager SLiM has been replaced by SDDM.” on NomadBSD ?

1 Like

But I am still using NomadBSD 130R-20210508, not upgraded it to NomadBSD 131R-20221130. All apps being updated are from and to the running 130R…

I think I have a track

I remove “picom” from Autostart Settings and I don’t have these slowness anymore.
The package has been updated

Maybe it will work for you

For testing I put picom back at the end of the list from Autostart Settings. I rebooted, for now it seems to work, to be seen over time.

I have a doubt but it seems to me that the pico file is present twice in the autostart settings. Is it a mistake on my part or is it during the update? To be checked if it is not present twice.

I use NomadBSD 130R-20210508 yet, my DSBAutostart is empty, and there is no ‘picom’ entry in /etc/rc.conf

I could not find a way to update apps, so I decided to upgrade to the new release. Thanks to the devs, I have successfully installed NomadBSD 131R on the USB stick, updated all apps via Octopkg, and am now ready to upgrade HDD too. I have backed up my data and am looking for some guide on how to restore user settings and data assets. Any links or suggestions?


So the new installer successfully wiped my hard disk and installed NomadBSD 131R-20221130, ending the same black screen. One entry in a log looks unusual to me – “permission denied to $HOME path”:

I am a bit confused: what these double signs // mean? Permissions to /home/nomad/.config/fish/ are 755, and 700 to ~/.local/share/fish/, an owner of both directories is nomad:nomad. These directories owned by vladas on HDD, permissions the same, although there are created two similar home paths: /home/vladas/ and /usr/home/vladas/.

Unfortunately, NomadBSD 131R on USB worked quite smoothly only the first time. Sometimes SDDM starts as a black screen, sometimes requires to login and refuses to accept it, sometimes even a shell (Ctrl+Alt+F1 or F3) refuses my user password (although accepts it as root), and sometimes (as now) lets in, but works very slowly. These log entries may be related:

NomadBSD dbus-daemon[1636]: [system] Failed to activate service 
'org.freedesktop.PolicyKit1': timed out (service_start_timeout=25000ms)
NomadBSD kernel: vm_fault: pager read error, pid 1802 (sddm)
NomadBSD kernel: vm_fault: pager read error, pid 1831 (Xorg)
NomadBSD kernel: vm_fault: pager read error, pid 1990 (plank)

Wow! I have found an obstacle: permissions (755, 700) and an owner (vladas:vladas) of the home directory and its link are set correctly in HDD, but named as /usr/home/nomad/!

Reinstalling did not help, but renaming manually to vladas was enough for SDDM to accept and work smoothly.

Not quite: a screen started black, although alive, thus it was enough to find and selected ~/Wallpapers/nomadBSD-2k.jpg

Sorry, I used to look at log entries first. @bsd276, you are right: removing the duplicate ‘picom’ from Autostart Settings fixed SDDM in USB installation too – thank you very much!

Dear devs, please fix these two simple bugs.


Great !

I have created an issue in github

I have been using NomadBSD for 2 years every day and NomadBSD is useful for me.

It’s a very good persistent live system.

Good job

1 Like