Accelerated Graphics detection failure on Macbook Pro Retina

Hello Everyone,

First and foremost I would like to thank the Dev team for
their hard work in creating NomadBSD !

I feel very fortunate to have come across such an easy to
use persistent USB solution.

I have experienced a difficulty when booting the system on
my late 2013 15" Macbook Pro Retina laptop, in that if the
“generic” graphics system is selected the system starts up
on the desktop as expected and runs well, but the Mac’s
HDMI output is non functional, and if the “autodetect”
accelerated graphics option is selected the system remains
in command line mode and doesn’t start up the desktop.

My particular laptop has both dedicated Intel Iris Pro graphics
and an NVIDIA GeForce GT 750M graphics card with 2 GB
of video memory.

Any suggestions as to how to get the system to recognize
and use the NVIDIA card in order to activate the HDMI
output would be most helpful and appreciated.

Thanks for your Assistance,



can you disable one of the GPUs in your MacBook’s BIOS/EFI?

Hi mk,

Unfortunately i don’t think that will be possible, because i am unable to access
the laptop’s EFI / BIOS.
( I tried rebooting with two hotkey variants i thought might allow access
“Option+command+O+F” and “option+command+0+F” but the laptop just boots as usual ? )

I will look further into how i could access the machines EFI / BIOS to disable the integrated
Iris graphics asap.

After reading your suggestion in the post titled “Intel Iris Pro 580…”
a tried the “startx” command after having selected the “generic” graphics driver
but an error was returned which read:

“Cannot run in framebuffer mode, please specify bus addresses for all framebuffer devices”

( see attached screencap - sorry for the poor quality )

Thanks Again for helping me with this difficulty mk,



Select autodetection for the graphics card from the menu. Then when you reach the login prompt, log in as root, and take a photo (or multiple if it doesn’t fit) of the screen after executing the following commands:

# pciconf -lv | grep -B3 display
# grep EE /var/log/Xorg.0.log
# cat /usr/local/etc/X11/xorg.conf.d/10-*

Hi again MK,
Here are the requested results:

Thank you for your assistance with this problem : )

That’s interesting. What does sysctl hw.pci.default_vgapci_unit say?

Hi MK,

The terminal seems to have returned simply “-1” ?
( not a very informative response, imo )

I’ve been having a look at the FreeBSD handbook in order to respect the precept “RTFM”
and came across a mention of the idea that the machine’s ACPI routine might be passing
incorrect data to the Nomad boot process and wondered if that could be contributing to
the problem ?

  • Also, if you wouldn’t mind, could you suggest the best reference material i could use
    to become more familiar with FreeBSD and NomadBSD in particular ?

    ( I’ve been living in “userspace” on Macs & PCs for years now
    and although i used to program in BASIC ( lol ) and did some work with HTML
    I’m basically clueless as to Nomad works under the hood. - something i’d like to rectify )



Ok, now I know why the autodetection failed. Please add hw.pci.default_vgapci_unit=0 to /boot/loader.conf. Then reboot, and try autodetection again.

Good resources are the FreeBSD Handbook, and Absolute FreeBSD by Michael W. Lucas

If you want to know how NomadBSD works in detail, you need to read the configuration files, and source codes. There is no developer documentation yet.

1 Like

Hi mk,

Sorry for such a newb question, but i don’t know how i could edit the loader.conf file.

I can boot my MBP into either OSX or WIndows 10 Pro, can i edit the file from within
either of those ? or if not, is their an editor i can use from the Nomad system terminal

  • or could i select the default graphics solution at boot up and use an editor from the
    Nomad desktop ?

  • Also, where would i find the file ? - in the root directory on the Nomad drive for instance ?

& thanks for the referral to “Absolute FreeBSD” i’ll be sure to check it out.


Boot NomadBSD, login as root, or open a terminal and use su to become root. Then execute

echo "hw.pci.default_vgapci_unit=0" >> /boot/loader.conf
1 Like

Thank You Very Much mk !!

Your suggestion to use the echo command worked !

I’m now able to boot the drive and both my laptop display ( 2880 x 1800 px )
and the HDMI output running to a Samsung TV ( 3840 x 2160 px )
are working simultaneously : )

I’ve got many more questions, but will hold back on them
until I’ve had some time to review the resources you suggested
in keeping with “RTFM”.

Thanks Again for your invaluable assistance,

  • R



1 Like