1.3.2 Problems with OctoPackage

I installed 1.3.2 on my USB and also on my computer. I tried a Dell laptop and a Thinkpad t480. With both machines I had the same problem. When I upgrade/update the packages on the Octopackage it hangs up and doesn’t open anymore. I also can’t exit my system. If I go to the leave button it doesn’t do anything. I can’t logout and can’t use the package management.

This is resolved by running the following commands (this is in the errata for 1.3.2).

Qt5 applications do not start after upgrade
After a pkg upgrade Qt5 applications abort with the message Cannot mix incompatible Qt library (5.14.2) with this library (5.15.0)
Reinstall x11-themes/qt5-style-plugins:

pkg delete -y qt5-style-plugins

pkg install -y qt5-style-plugins

This sort of resolved launch issues for me. I have noticed that QT applications take a lot longer to launch now. Also OctoPkg now asks for the user password instead of the admin password. It then errors saying the user isn’t authorized to run the command.

I haven’t resolved those issues yet.

I followed the advice above. This solved the problem with the Octopackage getting stuck. But I still can’t log out. There is no way to shut down the system. I click the logout button and nothing happens. There is also still some quirk somewhere that gives me the feeling that the system isn’t stable.

The only way that got it fixed for me is going to the command prompt and type:
pkg -y lock e2fsprogs
and then the tricky one:
pkg upgrade -f -I
Get some coffee it’s gonna be a long wait because all update packages will be installed again now but this time enforced and all install scripts will be ignored but that should be no problem :stuck_out_tongue:
reboot by console press ctrl+alt+F1
and then ctrl+alt+delete.
Or just type reboot (silly me :P)

1 Like