1.3.1 Not Booting

I prefer installing NomadBSD to my system drive. I have 1.3 installed on my Dell Inspiron, and I love it.

I tried installing 1.3.1 on my other computer to check it out, and the problem is that when I install to my hard drive, it doesn’t boot unless I leave the live USB in the slot. It’s like it doesn’t write the boot record to the ssd. Any advice?

Or - is there a way to upgrade to 1.3.1 rather than going thru a reinstall? I’m not really looking forward to reinstalling and re-configuring everything.

Hi @darkoverlordofdata,

we haven’t made any changes to the installer that could explain that behavior. Did you enable lenovofix? The reason we changed the image’s partition layout from GPT to MBR was that some systems, like Dell, refuse to boot if the lenovofix attribute is set. A NomadBSD installation, however, uses GPT. Try

# gpart unset -a lenovofix adaX

Replace adaX by the device name of your SSD.

That worked - thanks, @mk1 !

Some details: I rewrote the usb, and tried again. Still didn’t work. I made sure I wasn’t setting the lenovofix flag. I started over again, refreshing the usb. This time I used gpart before I ran the install. This time it worked. But when the install finished, the desktop was hosed. I clicked on any icon in plank, and the icon changed but the app didn’t launch. It seems like something gets corrupted in memory.

Aha! It was a bios issue. I installed the latest BIOS from the ASUS website, and NomadBSD installed without incident. This is on a ASUS ZenBook UX303UA.