NomadBSD 140R: Upgrade of perl5 from 5.34.1_3 to 5.34.3_3 not working

Hi - On NomadBSD 140R-20231121 (64-bit/x86-64/amd64, ZFS), I’m having trouble upgrading ‘perl5’, please see below. Any ideas? - Thanks!

Updating FreeBSD repository catalogue…
FreeBSD repository is up to date.
All repositories are up to date.
The following 2 package(s) will be affected (of 0 checked):
Installed packages to be UPGRADED:
perl5: 5.34.1_3 → 5.34.3_3
Installed packages to be REINSTALLED:
qt6-base-6.5.3 (required shared library changed)
Number of packages to be upgraded: 1
Number of packages to be reinstalled: 1
Fetching [1/2] perl5-5.34.3_3.pkg
Fetching [2/2] qt6-base-6.5.3.pkg
Checking integrity… done (0 conflicting)
[1/2] Upgrading perl5 from 5.34.1_3 to 5.34.3_3…
pkg: Fail to create hardlink: /usr/local/bin/.pkgtemp.perlbug.FdERVQ9eRI5q /usr/local/bin/.pkgtemp.perlthanks.7HXP0BINdTs2:File exists
[1/2] Extracting perl5-5.34.3_3…
Command finished with errors!

This error is the same one I got a few days ago, along with the same one for qt6-base, as seen in the following screen.

It is the same error already reported in Neither ZFS nor UFS and Fail to create hardlink NomadBSD version 132R-20231013, without this complaint having any value.
The only solution I have found is to block both packages and wait for someone to fix this bug.

Thanks for the screenshots.
The situation here is 100% identical.
Good to know that the error is reproducible.
For the time being, I have have locked the old version of perl5 in OctoPkg.

This won’t be fixed, it has to do with the filesystem used by nomadbsd not compatible with hardlinks. It’s best not to update at all and just wait for a new nomadbsd image or you can install freebsd on a usb stick which runs like a charm for me running XFCE on it.

I installed NomadBSD (User: “Nomad”) from my original USB stick to another USB stick (User: “Settler”) using the built-in NomadBSD installer.

Then on the “Settler” NomadBSD USB stick, upgrading perl5 and reinstalling qt6-base worked as expected in OctoPkg, see below.

Thanks to Rainer for the crucial tip in this thread:
Erfahrungsbericht NomadBSD 14 ZFS


1 Like