Laptop failed to recognize nomadbsd in USB stick

Hi, I was trying to boot a Dell laptop by using nomadbsd in a USB stick, however, after I press F12 I didn’t see the USB stick popping up as an option to boot. I was able to boot my desktop PC with it, and I was able to boot that laptop using the same USB stick with Ubuntu. Any thoughts?

hi Tfcheng,

if you are in the Bios and see no USB boot options than your PC has no USBboot option.
what you can do is downloading the freeware SUPERGRUB 2 .iso
here is the link :slight_smile:
https://www.heise.de/download/product/super-grub2-disk-55737

Burn this image to a CD ROM with your burning program such like IMG Burn ISO Burn

Plug the NOMADBSD STICK in your computer.
Boot your computer from CD Drive with this superGRUB 2 boot disk.
You see the menue and press ENTER.
Now you see many boot options.
Try it out what NOMADBSD IS.

That will work.

Hi @Tfcheng,

disable Secure Boot, or try to enable CSM.