Installing Nomad to hard disk - boots to command line login and that's it

Hello

I created a Nomad USB, booted up just fine UEFI, looks great. Used NomadBSD installer to install to my hard drive since I want to use Nomad full time. Shutdown, removed USB, started back up, Nomad kernel goes through the motions and arrives at CLI login. I enter the username and password for the user i created. DE doesn’t start automatically so I knew something wasn’t right. I assumed that I could just install to hard disk and use Nomad as usual sans USB.

Could someone help me out? I am new to BSD and learning more and more each day. I did not expect to have to re configure everything in command line but that seems what I will have to do which is a bummer since Nomad is already set up perfectly for my liking.

Thank you soooo much for any help you can provide. Can i expect Nomad to function installed to hard drive or should I just stick to USB? Thank you!

Chris

irc: unclechris3

Hi @crldb,

is your system using an NVIDIA graphics card? If so, see the Errata. Look for HDD/SSD installed NomadBSD doesn’t start the GUI on systems which require nvidia-driver > 390

Hey MK

For the python upgrade, how do I do this?

Change the shebang of dsbxinput and nomadbsd-chusr:

sed -i ‘’ ‘s/python3.7/python3.8/’ /usr/local/bin/dsbxinput

sed -i ‘’ ‘s/python3.7/python3.8/’ /usr/local/bin/lbi-gui

sed -i ‘’ ‘s/python3.7/python3.8/’ /usr/bin/nomadbsd-chusr

sed -i ‘’ ‘s/python3.7/python3.8/’ /usr/local/bin/ipfwGUI

Do I literally just type these lines into command line? That’s what I figured but just making sure. Thank you for helping get this amazing system working well!

Yes (except for the # which just indicates a root prompt).

Hello guys.

I got the same problem Chris described above but with my NomadBSD USB flash drive I created a few days ago. When I boot into my NomadBSD NVMe SSD install on my Laptop
(an HP Laptop 15-db1105-ng; detailed description at the manufacturer’s website: HP Notebook - 15-db1105ng Produktdaten | HP® Kundensupport )
it just works fine as you would expect on a normal NomadBSD install but when I boot into my NomadBSD flash drive, it tries to load the appropriate drivers (the amdgpu drivers) but fails to do so and I don’t know why this is the case.

Anyways, if anyone is willing to help and submit me a solution it will be appreciated. Thank you for creating such a great OS.

I should also mention that I tried to boot it up from an home-grown USB flash drive made up off of a SanDisk(R) Ultra A1 128 GB microSD card put into its appropiate cosupplied microSD to SDXC card adapter and all of this was plugged into an appropiate USB adapter by hama(R).

Tested this configuration on another computer and everything worked like a charme. Looks strange to me but I can live with that as long as it will boot up from my main laptop as it did on this computer I tested this on.