Installation NomadBSD on a usb key failed on reboot

Hi. I have installed (linux method) nomadbsd-1.3.i386.img on a usb key (8Go) but the reboot leads to this message : "“Automatic file system check failed : help! ERROR: ABORTING BOOT … Enter full pathname of shell or RETURN for /bin/sh:”. Any help please ? (I run this on an Acer Aspire One A110 Bb, Intel Atom 1,6Ghz, Ram 1Go, Intel 945GSE Express)

The device specs don’t matter I honestly don’t see why we continue to have those. this seems to be a bad dd I would try zeroing out that usb also you should try the 1.3.1 version https://mirrors.cpettington.com/nomadbsd/nomadbsd-1.3.1.i386.img.lzma and doing the xzcat nomadbsd-x.y.z.img.lzma | dd of=/dev/sdX bs=1M

I have tried the 1.3.1 version but it’s impossible to extract the file (nor with the tool or commands under Linux, nor with 7zip under windows). That’s the reason why I have tried with the 1.3 version.

it’s compressed using lzma 7zip and xz on Linux should extract it if it was downloaded correctly.

The sha256 of my download was correct.

xzcat cats the contents and pipes it through dd not sure why you need to “extract it” first.

You mean that xzcat doesn’t extract the file ?

I have downloaded again the 1.3.1 version and installed it through this command xzcat nomadbsd-x.y.z.img.lzma | dd of=/dev/sdX bs=1M ( xzcat nomadbsd-1.3.1.i386.img.lzma | sudo dd of=/dev/sdc bs=1M for my case). It seems that the terminal has made the job but the key doesn’t even boot.

well fails to boot can be many things, if you have that secure boot garbage it wont boot, if you have UEFI and no Legacy it will fail to boot. if you managed to dd something using the wrong device it will fail and the list goes on and on.

however you can try xz -d file.lzma and do it that way then dd bleh the extracted file if thats the case you may want to ask the devs to rethink that way if it doesn’t work.

I have legacy. It boots correctly with the 1.3 version and I usually don’t have problem with other distros. Thank you for your help but I give up.

before you give up, try a vanilla FreeBSD and see if that boots up fine.
https://download.freebsd.org/ftp/releases/i386/i386/ISO-IMAGES/12.1/FreeBSD-12.1-RELEASE-i386-memstick.img

im just curious if this is a img issue or something else.

Maybe later but now I am fed up. Have a good day.

as is expected, non techy people just want shit to work. spending hours just to boot will make any newbie move away. You as well.

If you do try later, I am interested in what you may find. Please let us know your results if you do decide to try again later. Take care.

1 Like