Green around the gills

Hello … I’m am quite new at NomadBSD (total novice) and have it up and running pretty well on a Lenovo G50-80 laptop (with no HDD, no less) but I do have a question. I downloaded the latest version onto a Sandisk 16GB USB 3.0 stick. I can boot from it in either of the laptops 2.0 sockets but not in the one 3.0 socket it has. The 3.0 socket works fine for a USB mouse as well as an external optical drive. Any ideas on the reason for this ? I’d really like to boot in that 3.0 socket to see if it would speed things up a bit.

Hello! I am a novice too with NomadBSD, but what I would suggest is that you try a different Linux distro on the same USB port. I somehow doubt that it is a NomadBSD specific problem, more likely a hardware problem, but at least you could find out.

Thank you, rayburn. Looks like there aren’t many ideas on here on my problem. The strangest thing of all is that the same version on a USB 2.0 stick will boot fine in that same socket.

It is strange then and probably a quirk of that particular USB stick. Have you any other USB 3.0 sticks to try? I have around six of them here as I am always experimenting with new distros!

It does indeed seem to be a hardware problem. I tried another USB 3.0 stick and it wasn’t recognized in the 3.0 socket either … but worked fine in the 2.0 ones.

afaik BIOS often do not have USB3 drivers. If the USB3 ports do not work in the running OS either I’d start troubleshooting there and get the needed drivers if that doesn’t work I’d consider it a hardware issue.
I do not know how to install drivers to a BIOS.

Thanks for the responses. That’s pretty much the conclusion I had come to h474rd.

Sometimes usb sticks have problems with certain machines and sockets.
Sandisk is known for making problems and some Linux derivates advice not to use a Sandisk stick.
I avoid such Sandisk sticks and only buy high quality stick from well known vendors. Don’t use the very cheap ones from a dump bin.
It could be a problem with the stick or the socket. But I think it could be mainly the stick. Try another OS and look there if the speed is okay and then come back.

I also have tried a Samsung 3.0 stick with exactly the same results. Thank you for your input.

I searched a little about your model and have seen some complaints about the 3.0 port, so something is up. During that era I have personally seen where the 3.0 port will be able to act as a storage / file medium, but the ability to boot has been disabled, mangled, or forgotten by the manufacturer.

One long-shot might be to go into your bios and see if you can change it to “legacy” or “CSM” mode and see if that makes any difference. You may not even have that option if the box came with Windows7, but again - a long shot - which may not work, but worth a shot.

In another similar instance, I have a few Intel ComputeSticks that act similarly. I can use the micro-sd card port to boot from on some, but on another model that ability has been purposely disabled. Tore my hair out yet again to finally get an admission from the manufacturer about that being disabled for security reasons.

Argh - this consumer stuff right? :slight_smile:

Hint: although beyond the scope of the simplicity of NomadBSD, to work around issues like this would be to instantiate the boot from the usb 2 port, and have the rest of your working partions being pointed to on the faster usb3 port for the pickup in speed for normal operations. Would make an interesting project, but may not be practical in the long run depending on how far you want to take it.

Thank you for your ideas, Rando. Some excellent thoughts indeed. I did try changing the BIOS to legacy boot but it didn’t solve the problem. I may try your idea of booting in 2.0 and doing everything else from the 3.0 port. I’m not sure I’m knowledgeable enough to accomplish that at this point … but it is an interesting concept.

What would be considered a good quality USB to use? i thought SanDisk was a good brand, it’s what i’m using at the moment

I could be wrong … but as far as I know … Sandisk is a high quality brand. I believe the warnings you may have seen were referring more to those cheap, “no-name” brands you might find in discount stores.


Sandisk is fine, and I also use Samsung for both USB, SD, and micro-sd. I’ve used Crucial too. Use one rated for usb3 at least if your machine has a usb 3 port.

Avoid deals “too good to be true”, or other bottom of the barrel deals. Stick to reputable dealers to avoid counterfeits.

Over-provision if you can. That is, given the choice between a 16b stick, vs a 32g stick, I’d choose the larger one if the budget permits. How much you intend to store will also determine size obviously. My minimum - regardless of how small an installation is, would be at least 16gb to ensure healthy over-provisioning. Or if you already know how much you’ll be storing - double it at least.

Why over-provision? Wear-leveling.

Even if your initial installation only takes up a small part of your stick, and perhaps you are only going to use it for simple tasks, the additional cells of the larger sticks provide plenty of “spare cells” with which the sticks internal drivers spread out wear.

There are a lot of other nit-picky technical issues one can get into, but most of the time I find them to be marketing, or users “bench-racing” specifications in their blogs. :slight_smile:

Sounds like some great advice !!! Thank you.

any preference for USb stick or using the inbuilt card reader?

I have never tried the card reader … and I’ve always had good results with both Sandisk and Samsung.